Ati Radeon 6950

Discussion in 'Mac Pro' started by dtechlogic, Jan 20, 2013.

  1. dtechlogic macrumors regular

    Joined:
    May 15, 2011
    #1
    Hi guys,

    Well guys i am here to find the direction or someone can direct me to the right direction to able to flash my XFX Ati Radeon 6950. I have look around but most of the instruction are not clear. The XFX 6950 2GB is stuck on the protected bank. The switch on top is broken off. I don't know if they did this by intention so that it cannot be flashed. I called XFX about it but they came back with a smart A$$ answer. Anyways my coworker is willing to trade with me for his Ati radeon 6870 1GB. will the 6870 Work with the mac pro I have (mac pro 5.1) or is it best to flash the 6950. But can anyone point me to the rom with the EFI 64bit for 6950 or the 6870 if i trade with my coworker. Well i am in desperate need or maybe someone in LA, CA can assist on flashing it.

    Model Name: Mac Pro
    Model Identifier: MacPro5,1
    Processor Name: Quad-Core Intel Xeon
    Processor Speed: 2.4 GHz
    Number of Processors: 2
    Total Number of Cores: 8
    L2 Cache (per Core): 256 KB
    L3 Cache (per Processor): 12 MB
    Memory: 32 GB
    Processor Interconnect Speed: 5.86 GT/s
    Boot ROM Version: MP51.007F.B03
    SMC Version (system): 1.39f11
    SMC Version (processor tray): 1.39f11
     
  2. dtechlogic thread starter macrumors regular

    Joined:
    May 15, 2011
  3. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    6950 doesn't work well in Mac. Your best bet is to return it and get an Nvidia GTX 660 or something like that.
     
  4. Phrygian macrumors regular

    Joined:
    Nov 26, 2011
  5. dtechlogic thread starter macrumors regular

    Joined:
    May 15, 2011
    #5
    Well, my buddy is returning my gtx 670 2gb. I am going to sell my ati radeon 6950 on eBay. The software I use often is adobe premiere pro after effcts and photoshop
     
  6. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #6
    Wait, you have a 670? Why aren't you using the 670?
     
  7. dtechlogic thread starter macrumors regular

    Joined:
    May 15, 2011
    #7
    I gave it to my buddy. He called me and said that he is going to dismantle his pc and will be returning my gtx 670. I just gave it to him last friday. He did not even use it. Anyways the reason i gave it to him. I was discourage because my Freaking mac pro 5, 1 fans keeps running at full speed after apple has replace the power supplly, logic board and the backpanel board. Still they can't fix it. The good news is i do still have apple care until march 2014. This Friday i am taking it back to them for the fan issue. I am going to try to see if i can convince them to replace the system. As i type this up. i just turn on the mac, i am at the login screen the freaking fan is loud and going at full speed already without running anything. This is sucks. I have taken it to them four times. Already. I hate going back but it looks like i have too. (Also forgot to mention that the fan issue started happening after they replace the power supply, backboard, and logic board.
     

Share This Page