ATT Unlocked iPhone 3G now wont go!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by moggi1964, May 6, 2012.

  1. moggi1964 macrumors newbie

    Joined:
    May 6, 2012
    #1
    So ATT unlocked my iphone and Apple sent me the prerequisite email to go through the procedure.

    That all worked fine and I installed a t-mobile sim and it recognised it. I slid the unlock screen slider and up comes:

    "Edit home screen" blah blah blah so I Press the "Dismiss" button and NOTHING!

    I have reset the phone; DFU'd the phone; put in an ATT sim card and tried that; took it to Apple retail and they just shrugged; took it to ATT retail and they said an Apple problem. I even tried doing a jailbreak (even though it wasn't necessary) and that was successful but I STILL have the same problem.

    Thing is; I only want to use the iPhone as a standalone GPS. I will use offline mapping meaning that I don't need to connect to a cell tower just the GPS satellites. So I won't even use it is a phone or a data transfer device! The t-mobile sim is my Virgin Mobile sim for the UK which doesn't cost me anything monthly if I don't use it.

    Any ideas anyone?

    Thanks.
     
  2. moggi1964 thread starter macrumors newbie

    Joined:
    May 6, 2012
    #2
    Just spoke to Apple and my phone is a paperweight. Must be a hardware issue they say (though it only happened after unlocking) and a replacement is $149.

    So it's in the bin.

    Oh well! :(
     

Share This Page