ATT Uverse / Motorola NVG510 gateway - iPod gets IP, MacBook doesn't

Discussion in 'macOS' started by hiroo, Mar 11, 2013.

  1. hiroo macrumors newbie

    Joined:
    Mar 11, 2013
    #1
    Trying to help a friend with this problem and tried a ton a basic troubleshooting already. She has ATT Uverse internet service, connecting through a Motorola NVG510 gateway. She has an iPod touch and a MacBook Pro (C2D-era).

    Everything was working ok, until a few days ago when she let the MBP's battery drain completely and since then the MBP hasn't been able to connect to the route. Neither ethernet nor WiFi work for the MBP.

    The iPod touch connects to the to the gateway via WiFi just fine and can access the internet. ATT has already been out and says the Internet connection is fine and says the MBP problem is her problem, not theirs.

    If the MBP is connected via Ethernet, the connection shows green, but it never gets an IP address via DHCP from the gateway. Same when connected via WiFI, the wireless connection is good, but it doesn't get any IP address.

    So far we have tried without success:
    - rebooting MBP
    - rebooting gateway
    - factory reset of gateway
    - wired connection or wifi connection with same lack of results
    - creating a new Location in the Network Preference Pane
    - setting Ethernet to manually configure to 1000BT or 100BT or 10BT
    - deleting gateway from the saved WiFi networks and recreating it
    - clicking Renew DHCP lease many times
    - turning WiFi off/on

    Any other suggestions on how to fix this problem?

    It seems like the problem lies with the Mac somehow not requesting IP from DHCP correctly, or not acknowledging the response, or being disallowed by the gateway somehow.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Have her Reset PRAM and/or Reset the SMU. See if this helps.

    Also check the Macs System Preferences->Network pane and use that pane's "Location bar to make a custom named new Location (make sure you save all along this way) and see if that helps.
     
  3. hiroo thread starter macrumors newbie

    Joined:
    Mar 11, 2013
    #3
    The solution turned out to be moving /Library/Preferences/SystemConfiguration and rebooting to force the system to recreate that config file.
     

Share This Page