ATT Wi-Fi calling works perfectly!

Discussion in 'iPhone' started by cc999, Oct 16, 2015.

  1. cc999 macrumors 6502

    Joined:
    Jul 15, 2008
    #1
    Turned on the Wi-Fi calling option on my Apple bought SIM FREE iPhone 6s 128 gb model and I am happy to report it works perfectly. Calls are unbelievably crystal clear. A great option to have especially traveling.


    CC
     
  2. nepalisherpa macrumors 68020

    nepalisherpa

    Joined:
    Aug 15, 2011
    Location:
    USA
    #2
    Just so you know, Wi-Fi calling is not free if you are traveling internationally.
     
  3. HEK macrumors 68030

    HEK

    Joined:
    Sep 24, 2013
    #3
    Awe you ruined the surprise one month after the vacation when the $2,000 phone bill would arrive.

    Turned on wi-Fi calling great clear sound. Funny part is goes so fast son's voice comes on and phone has not even rung yet. Was sort of weird.
     
  4. Eileen89 macrumors 65816

    Joined:
    Aug 12, 2014
    #4
    I'm glad to hear that it works well on the Sim Free model. I have one coming in a week or so and will be using it on AT&T's network.
     
  5. LLL1424 Contributor

    LLL1424

    Joined:
    Oct 24, 2005
    Location:
    Washington, D.C.
    #5
    Moderators, merge this with the many other threads about AT&T wifi calling. We don't need threads about how great a feature is when there's tons of threads claiming the same exact thing.
     
  6. HEK macrumors 68030

    HEK

    Joined:
    Sep 24, 2013
    #6
    So true only one thread allowed saying something works well. But ok to have bunch of chip gate threads. How about combining those.
     
  7. N54TT macrumors member

    Joined:
    Nov 6, 2013
    #7
    Try calling another att iPhone that's on 4g/lte and report back if it's still perfect.
     
  8. HEK macrumors 68030

    HEK

    Joined:
    Sep 24, 2013
    #8
    The one time I did that today, yes it was much clearer than before. I was on wifi and son was in car on LTE, both AT&T. I had understood the benefits would only be seen if both were on wifi. However to my surprise this call was much clearer. Will keep monitoring.
     
  9. N54TT, Oct 16, 2015
    Last edited: Oct 16, 2015

    N54TT macrumors member

    Joined:
    Nov 6, 2013
    #9
    Hmm wonder if they fixed the bug already. When using wifi and calling another att iPhone. The lte phone could not hear you.

    Just tested it and it still seems to happen
     
  10. HEK macrumors 68030

    HEK

    Joined:
    Sep 24, 2013
    #10
    Didn't experience that. Hope I won't
    Thinking back about six months ago prior to Wi-Fi phone being on I did experience not being able to here other party. We were both on LTE. Cycling the data off fixed that back then. Did not repeat after about two weeks.
     
  11. rigormortis macrumors 68000

    rigormortis

    Joined:
    Jun 11, 2009
    #11
    is there a way you can check with verizon and sprint and see if they say your device is compatible?

    i have a t-mobile unlocked, and its failing verizon and sprint's imei checkers

    i haven't actually had them try to activate it, i don't really want to sign up


    i thought about returning it, but its been longer then 14 days

    im thinking if i switched it out for a sim free, i would get the same response from verizon and sprint
     
  12. jeepik macrumors regular

    Joined:
    Oct 2, 2009
    #12
    It works well on my home wifi but at work, the phone is stuck on barely any signal..as soon as i turn off wi fi calling it drops wifi and gets a full cellular signal..i think this is still very buggy
     
  13. cc999 thread starter macrumors 6502

    Joined:
    Jul 15, 2008
    #13
    A friend of mine had the Sim free version and activated on Verizon no problem. The Sim Free phone
    is the better choice vs the T-Mobile unlocked.

    As a side note if you bring the phone into Verizon Store they can get it activated. The IMEI is not listed on their system because its not a Verizon branded phone.

    CC
     
  14. HEK macrumors 68030

    HEK

    Joined:
    Sep 24, 2013
    #14
    The work wifi is configured to not allow it for security reasons. The IT people at your work are not up to date. Good luck getting them to change settings.
     
  15. BarryL macrumors 6502

    Joined:
    Dec 2, 2012
    #15
    So while traveling outside the USA, you can't flip the device into airplane mode, connect to Wi-Fi and made calls to USA? Or AT&T charges regular international rate for this?

    T-Mo allows calls back to USA from abroad at no charge on Wi-Fi calling.
     
  16. jeepik macrumors regular

    Joined:
    Oct 2, 2009
    #16
    I am the IT People ;)

    Its an open wifi network inly difference between home an work network is the vendor of the router equipment
     
  17. HEK macrumors 68030

    HEK

    Joined:
    Sep 24, 2013
    #17
    I read on here somewhere that some ports are not open automatically on some equipment. Has to be set. The airport has these open by default. Don't recall that the technical name. Hate routers and modems with a passion. Won't even go into the ordeal going to my own modem from Comcast rental.
     
  18. mtneer macrumors 68020

    mtneer

    Joined:
    Sep 15, 2012
    #18
    I get the welcome splash screen when I opt to turn on WiFi calling on my AT&T iPhone 6S+. However, when I get past the T&C page, I get a "Oops something went wrong and try again in a few minutes" error. Clicking OK takes me back to the T&C page and the endless loop continues. This has been ongoing for the past week and a half, no change at all.
     
  19. clunkmess macrumors 6502a

    clunkmess

    Joined:
    Jul 28, 2011
    Location:
    California
    #19
    Has anyone successfully enabled Wi-Fi Calling on their AT&T iPhone 5s? My brother has the 5s on iOS 9.0.2 and the option isn't even there. I'm confused because Apple lists the iPhone 5c and up as compatible.
     
  20. AbsynthMinded macrumors member

    Joined:
    Oct 17, 2015
    #20
    Just to add on, it has worked consistently/reliably as well which was a personal concern since AT&T released it later than anticipated. Part of me thought they were using FCC regulations as an excuse because they didn't have it ready to go.

    To test it out, I put my phone in airplane mode and just turned on Wi-Fi for the past 4 days while on my home and work networks. Not only can I make crystal clear calls but I get all my SMS messages perfectly and SMS forwarding still works fine with other apple devices.
     

Share This Page