Attempted Fix=Fail help No sound - no camera

Discussion in 'iPhone Tips, Help and Troubleshooting' started by aintaverage69, Jan 31, 2011.

  1. aintaverage69 macrumors newbie

    Jan 31, 2011
    Hey all,
    So my 3gs had an issue where the UP volume button did not work at all.
    So I searched and found out about replacing the Flex cable
    I am fairly tech savvy and I figured I can do this...
    WOW those screws are the WORST
    So I swapped out the flex cable (now the vibrate switch is loose because I didint know how to bond the cable to the piece-if you know what I'm talking about)
    and put everything back together
    (I struggled quite a bit)

    I am positive I plugged all connectors in

    I turn the phone on and the volume button works ---but it says ringer (headphones)
    and I am getting no audio out - tried music and phone call
    BUT the head phones work... AND when you change the ringers in settings the sound comes out (WTF)
    and - lastly the camera doesn't work
    Please advise
  2. aintaverage69 thread starter macrumors newbie

    Jan 31, 2011
    Lots of views...
    no one has input?
    please advise i'm not sure what to do
  3. saberahul macrumors 68040

    Nov 6, 2008
    Ya, I'm one of the viewers who can't advise... hopefully someone will have a helpful reply for ya.
  4. aintaverage69 thread starter macrumors newbie

    Jan 31, 2011
    Heh well, at least I know people are out there
  5. surf2snow1 macrumors regular

    Feb 26, 2008
    I did the same thing last week. Camera and wireless suck, vibrate quit on me today.

Share This Page