Attempting to copy to the disk Macintosh HD failed

franinmuc

macrumors newbie
Original poster
Jan 29, 2019
7
3
Germany
Hi one and all,

I know that this question has been addressed before on this forum but I was not able to solve my problem. Perhaps my case is a little different. Don't know.

My friend sent me a USB stick on which she had copied several songs. I then inserted the USB stick into my desktop and tried to listen to the music on iTunes but got the message "Attempting to copy to the disk Macintosh HD failed. You do not have enough access privileges for this operation." So I thought perhaps I should first copy all the songs onto my Mac. I created a folder and moved all of them over. I later discovered that I could listen to half of the songs. Only half of the collection gave me the above message.

I then googled and landed up here. One suggestion offered was to use Cmd i to bring up the Get Info box, unlock it, and tick "Apply to enclosed items". This did not work. I tried doing this to the sub-folders and to the actual songs. (Thing is now that I've clicked that, when I go to the Get Info box, if I want to revert the action, I don't know how to do it. Sometimes this option does not even show up. Is that cause for concern?) I will assume that this change has no big impact on other actions in future.

Another suggestion was to go to the SSD and check what User was set to. I can't find where to access this information. Can someone tell me? My SSD is built-in. I am also not sure if that is the solution.

Does anyone have an idea what else I could do? If it is necessary to know, I have an iMac (early 2008) with OS X El Capitan.

Would be grateful for any tips.

Many thanks!
 

franinmuc

macrumors newbie
Original poster
Jan 29, 2019
7
3
Germany
Beyond your friend what is the source of these songs? Ripped from a CD? Downloaded from a song service?
Somewhere along the line the songs came from CDs. It seems she was able to listen to them. I've written to ask her and have yet to receive a reply but I think she had no problems, otherwise she would have told me and not sent me stuff which she could not have accessed herself.
[doublepost=1548770943][/doublepost]Since writing the above reply, I tried something else. I decided to see if using Quicktime would give the same results and guess what, I can listen to all the songs using Quicktime.
Ok, at least that problem is solved and I can listen to the songs on the computer.

But what I would really like is to have all songs on my iPhone and not just half of them. Seems like there is no quicktime for iPhone. And also, if I were to use Quicktime, how would I get all those songs over to the iPhone. Up till now, I have been synchronizing through iTunes.
 

Fishrrman

macrumors P6
Feb 20, 2009
17,481
5,676
OP:

Please try this simple trick (EXACTLY as I describe it), and then get back to us:

1. Insert USB drive into port
2. Wait for its icon to appear on the desktop
3. Click ONE TIME on the icon to select it (don't "open" it)
4. Type "command-i" (eye) to invoke the "get info" box
5. At the bottom of get info, there is a lock. Click it and enter your administrative password
5. In "sharing and permissions", there is a checkbox "Ignore ownership on this volume"
6. Put a check into it and then close get info

NOW try to copy files from the flashdrive to your Mac desktop.
Do things go better?

BE AWARE that the process I outlined above is DIFFERENT FROM the one you mentioned earlier.
 

franinmuc

macrumors newbie
Original poster
Jan 29, 2019
7
3
Germany
Screenshot 2019-01-29 16.45.47.png

Sorry some of it is in German. I did exactly as instructed and was able to do up to Nr. 4 but as you can see below, there is no lock for unlocking!
 

Fishrrman

macrumors P6
Feb 20, 2009
17,481
5,676
Ah, ok.

I just plugged in/unplugged a few USB drives, and now I see that the trick I described in reply 4 above seems to work ONLY with flashdrives that are "in Mac format".

The one you have is formatted fat32.

Does your friend use a Mac or a PC?

If he/she uses a Mac, ask to be sent a flashdrive that is formatted for the Mac with the files on them.

Perhaps then "the trick" may work for you.
 

franinmuc

macrumors newbie
Original poster
Jan 29, 2019
7
3
Germany
Nope Fishrrman, tried it and it did not work. I really appreciate your help.

However, some good news! :) While you were writing to me, I was writing back. :) I've solved part of the problems. (In addition to not being able to open all the music using iTunes and having to use QuickTime for half of them, I couldn't even sync the ones on iTunes/Mac with my iPhone. Had that grey dotted circle next to the name of the song. Searching on the forum for answers didn't help. I do have enough storage.)

Going to write here what I did in case someone else has the same problem.

I had all the songs (mix of iTunes and Quicktime readable ones) in a folder on my Mac. I just moved the whole folder to Dropbox on my Mac which then synchronized with my Dropbox on my iphone over wifi. And guess what, now I can listen to the music on my phone through the Dropbox folder on my phone.

However, when I try to access the song (I tried one) through Dropbox on my mac, it gives me the same message that I have no access, meaning I can't use iTunes but have to use Quicktime. I found that I could change how it is opened in the Get Info box, chasing Quicktime over iTunes. Strangely, a few minutes ago, after the moving to Dropbox was completed, I could listen to that same song on my Mac/Dropbox and it was played on iTunes! Totally weird!! Now it's gone back to square 1. But that's fine. As long as it can be heard one way or another, I'm happy.

And now when I open my iTunes on my computer with my iPhone connected to it for synchronization, the computer does not detect the iphone. But I'll check tomorrow after I reboot the computer. Groan! Time for bed. I've spent the whole afternoon and evening trying to fix this. :(