ATV 2 is stuck at boot (can't restore - "preparing apple tv for restore") - Solved

Discussion in 'Apple TV and Home Theater' started by dwain, Oct 19, 2011.

  1. dwain, Oct 19, 2011
    Last edited: Oct 21, 2011

    dwain macrumors newbie

    dwain

    Joined:
    Sep 11, 2010
    #1
    Hi,

    I bought my first Atv just 2 days ago. It came with the 4.1.1 ios version. I jailbroke it with greenpoison and installe xbmc with some great addons. Everything was ok until today. While in the menu of Nito TV it showed up that there was a new update. I guess it was for cydia. If I'm not wrong it was something like core-utils. Ayway I updated it and it asked me to restart. I did restart and I saw the apple logo on the screen for about 10 seconds. Then ATV should have started and the menus should have showed up at the moment but it didn't. It was trying to sync with TV's HDMI but it looked like it failed all the time and I always had black screen. Whenever I restart it I always get this.

    I decided to restore Apple TV to 4.1.1 original firmware. I downloaded the ispw file. Tried shift restore but I got 3194 error. Each time it was trying to communicate with Apple Server I was always getting this error. I launched tinyunbrella and started TSS server to get rid of that message. This time I didn't get that error. It started extracting the firmware. But when the message switched to Preparing Apple TV to update firmware it was always stuck. I tried many things. I plugged power cable, unplugged it, tried to update to 4.2.1 (4.3.1) and evet tried to update it to original IOS 5 just by clicking restore but it didn't work (This time I got an error 2005). I was always stuck in there. My computer is a PC. I tried the same thing at another windows laptop but nothing was changed. I thought maybe it could be from the cable but I could jailbreak the device without any problem. And the cable is not a bad one. It's Belkin.

    I don't know why the device went down after updating that core-utils thing. And I don't know what to do to restore it. I had these kind of problems with iphone sometime before but I could always find a solution.

    One last think I have in my mind is to try these on a Mac if I can find any around me. Other than that I don't know what to do. I hope you can give me an idea to try.

    Thanks.
     
  2. dwain, Oct 21, 2011
    Last edited: Oct 21, 2011

    dwain thread starter macrumors newbie

    dwain

    Joined:
    Sep 11, 2010
    #2
    I solved my own problem.

    First I already had the necessary firmware ispw file for 4.1.1 and my device's firmware was already 4.1.1 when it was stuck.

    I downloaded iFaith and then got the shsh from atv. After that I created a signed ispw file. Then iFaith updated my bootrom and with limerain it made ATV to be ready for restore on itunes.

    I opened iTunes and by clicking Shift + Restore I chose the ipsw file that iFaith created with the shsh file. Everything went ok. Now my ATV is back.

    But I've also found what caused this problem. It was firecore's atv flash beta 7. Because after I restored atv, I Jailbroke it with greenpoison and installed xbmc. Finally I installed atv flash but the problem happened again and atv didn't boot up properly. So I restored it again and this time I didn't use atv flash. Actually I really don't need to use it either. I don't think anything is necessary from it. Everything I need is already in NitoTV.

    iReb also is a good tool for those who are stuck at "preparing apple tv for restore" phase.

    Oh and just before doing all of these I'd also changed the USB port of the microUSB cable with the port on which I could always restore my iPhone without any trouble.
     

Share This Page