aTV 2 keeps losing home sharing

Discussion in 'Apple TV and Home Theater' started by MrMister111, Aug 21, 2011.

  1. MrMister111 macrumors 68000

    Jan 28, 2009
    Hi I have just got an Apple TV 2 (I already have an Apple TV 1). I use it with my iMac for iTunes home sharing. Everything is updated: iMac Lion v10.7.1, iTunes v10.4, Apple TV 2 v4.3. Th eApple TV 2 is wireless to an Airport Extreme, iMac is wired to it.

    Ive set it up and evrything seems to work fine. However when the Apple TV went to sleep, it showed "My Library" under computers, I clicked it, it then showed the list, clicked movies, but it said "no movies are in this library" or something similiar.

    I tried with all music, TV shows, Podcasts etc, and nothing. It was connected to network as have full signal. Also can browse You Tube etc. I was stuck. I decided to switch off Home sharing in settings, switched it back on, and tried again and everything was there!?!

    I've now had to do this everytime I want to browse my iTunes library. Movies stream fine once connected. Is my Apple TV broken? surely not, its only a week old!?

    please help
  2. Johnscone macrumors newbie

    Aug 21, 2011
    Mine has started doing the same , all updated and runnning lion on both mac mini and macbook pro, funny thing is when i used my ipad as a remote all the content was there
  3. MrMister111 thread starter macrumors 68000

    Jan 28, 2009
  4. Attonine macrumors 6502a

    Feb 15, 2006
    I have exactly the same problem, with both ATV 1 and ATV 2. If they have not been used for a day I get the "no movies" message, or TV shows, depends what i'm looking for. The solution for me atm is to quit and restart iTunes. I have just updated to iTunes 10.4.1, hoping this may fix the issue.
  5. somemacuser, Aug 22, 2011
    Last edited: Aug 22, 2011

    somemacuser macrumors newbie

    Oct 25, 2010

    Very similar problems -- if I leave the thing running, seems ok. If I let it sleep when I go to work/sleep, seems like 80% of the time it can't find / load my library (spinning gear, nothing, or reports no music).. I've been through 3 calls to apple support who have had me turn off homesharing in iTunes, reboot, reboot the router (apple extreme), restore from scratch the apple tv, tell me to not use the remote app, etc. etc. Nothing has fully fixed it. Nothing. It is the ONLY reason I bought the ATV. When its working, its absolutely the coolest thing ever. I have bought 3 of them for gifts for people as I was so enamored with the idea of packing up media for good...

    Just can't believe they can make such an amazing product with such thought and refinement, then screw up something basic, like having the network work reliably. Rebooting ATV sucks.
  6. MrMister111 thread starter macrumors 68000

    Jan 28, 2009
    I'm really disappointed. I have an Apple TV 1 but it gets so hot I had to switch it off when not in. I got an Aple TV 2 so could just leave on al the time, its so small and doesn't run hot (so far).

    I'm huffed that it has this problem, and looks like its rife around the net.

    Your post above was disappointing to, as you say you'e contacted Apple support, I was going to use my 1 allowed telephone support incident, to ask about the problem, no good if all they say is to reboot everything, put all back to factory!?!

    I have an iMac, Apple Extreme base station, Apple Tv so all Apple, thought it would work fine :(
  7. KOZOK macrumors member

    May 2, 2011
    The only solution that does anything for me is restarting itunes once the atv2 wakes up. Annoying but works.
  8. cdavis11 macrumors 6502

    Aug 31, 2009
    I've run into this issue as well as the "Loading Library..." hang that many people have been fighting.

    I found a couple of items that have mostly worked for me to reduce the problem:

    1) If you have your screen saver set to your photo library, reset it and choose one of the internal aTV screen savers.

    2) For some reason I can't fathom, turning off "keep itunes media organized" seems to have improved aTV performance as well.
  9. MrMister111 thread starter macrumors 68000

    Jan 28, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    Well restarting iTunes everytime if works is not a solution as it has to be "wife & kid" friendly!! ie just use the Apple remote nothing else to touch! ;)

    I want to keep my library organised though, I can't believe this helps?!?

    Really miffed messed today and still the same :(
  10. KOZOK macrumors member

    May 2, 2011
    You don't give your wife very much credit do you. And if your kids are old enough to be using computers they should be better at it than you are.
  11. charks macrumors member

    Jul 22, 2010
    I was having the same issues. Home sharing would work for about 10-20 minutes...then drop off. I ended up hardwiring my Apple TV via ethernet to the router. This mostly solved the issue...but it will still occasionally not recognize my computer...even though iTunes is up. Stopping and starting the home sharing in iTunes solves this for me.

    Regardless...this is disappointing...and my numerous calls to Apple haven't helped at all.
  12. ascender macrumors 68000

    Dec 8, 2005
    I have two ATVs here and this only ever happens on the one which is wireless rather than wired. Restarting iTunes is the quickest way to fix it for me.
  13. MrMister111 thread starter macrumors 68000

    Jan 28, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    Well I'm stumped then, I was going to use my one telephone "support incident" and call Apple to see if they can help, but it seems so widespread and if Apple are just going to tell me to report an factory reset everything that's no-good either.

    What level Apple support have you went to? I've heard there are various levels. Can I ask what they asked you to do, as I'll try it 1st and then if I call I can say I've done it all.

  14. macericpet macrumors newbie

    Aug 25, 2011
    I too have this same problem. Connection seemed to be lost at random times after a sleep.

    I opened a support case with Apple and after some back and forth they concluded that my unit is defective. It is clearly not.

    One of their suggestions was to keep it wired (which defeats the purpose of it) but it has kept my connection ever since. I have kept it this way in hopes of a fix. I'll keep waiting.
  15. slothrob macrumors 6502

    Jun 12, 2007
    One advantage of trying it wired is that it narrows down the problem to your wireless network, not an issue with the computer. Then you can focus your problem solving to just the wireless.

    There have been some problems cited with interference from other devices around the aTV2. Try moving it, and the computer, right next to the router and away from other devices. Then move one item, then the other.

    Also, try shutting off Sleep on your computer, to eliminate that as a problem. I have an intermittent problem with losing the connection after the computer has been asleep. It has nothing to do with the aTV2, but is due to the PC that I use to run iTunes, which needs to have the wireless connection "repaired" about once a week, for some reason.
  16. rayyu882, Aug 26, 2011
    Last edited: Aug 26, 2011

    rayyu882 macrumors member

    Jan 18, 2010
    I've been dealing with this issue since I got my ATV2s. It's so annoying. Both of my ATV2s are wirelessly connect to my AirPort Extreme, and sometime wake up from sleep they won't find my iTunes library, restart the ATV2 will fix the problem but they almost need to be rebooted in a daily basis.

    The problem is in ATV2 itself, not iTunes or wireless network related I believe. All my other devices can wirelessly see my iTunes library without issue.

    Apple, please fix this!!!
  17. Sweetfeld28 macrumors 65816


    Feb 10, 2003
    Buckeye Country, O-H
    I also have this problem, however I noticed that it seems to lose the connection when my MP, screen saver comes on, or if it falls a sleep.
  18. rayyu882 macrumors member

    Jan 18, 2010

    So base on the discussion on Apple forums, someone suggest the workaround is to have ATV not to sleep at all, I will give this a try.
  19. cguichard macrumors newbie

    Aug 26, 2011
    Same here in France... and no help from Apple

    I have exactly the same problem and applied the same "solutions" but nothing is satisfactory. It is extraordinary when Apple gives you as a remedy to wire the Apple TV! I think they are just not professionals on that one and the politics of the ostridge does not work with loyal consumers that we are.
    What we need is a real solution from Apple.
    Question: how can we make them help us?
  20. merrickdrfc macrumors 6502

    Jan 8, 2011
    I had the same problem and a restore of my ATV fixed it, was unbelievably annoying when it wouldn't work though :mad:
  21. MrMister111 thread starter macrumors 68000

    Jan 28, 2009
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    Well I'll try a restore but as it's brand new and setup can't see much difference.

    It's not much hassle to restore an aTV2 suppose as nothing synced.

    When you say restoring fixed yours, did this include all the time, when waking aTV from sleep, waking Mac from sleep etc?

  22. KenOzz macrumors member


    Aug 2, 2011
    Lincoln UK
    I have the same problem as you guys, the only way I can use my iTunes library is to sign into my network on my Apple TV2 each time I want to watch stuff

    This as only started after my Lion upgrade, the 6 months before that my Apple TV worked seamlessly and was in use daily

    Now its such a hassell I only use my Apple TV sparingly until Apple provide a fix, it very disappointing and very unlike Apple to drag their feet over a fix like this

    i think this is the first time ever I have been disappointed in Apple :(
  23. whooleytoo macrumors 603


    Aug 2, 2002
    Cork, Ireland.
    I'm having similar problems with a brand new (2 day) old ATV, so I don't think Restoring your ATV is anything other than a placebo.

    For me, if I'm just playing music through the Remote app in iPad, it works great. As soon as I switch to another use (using the Remote app ATV gestures, or playing a video via AirPlay) the ATV very often just seems to disappear. Sometimes I try turning off & on Home Sharing, or else AirPlay. Or maybe it just comes back by itself after a period of time and I think whatever I did fixed it.

    Would love a permanent solution to this. I might try an Ethernet connection to see if that helps.
  24. KOZOK macrumors member

    May 2, 2011
    I experienced the same thing repeatedly with using remote on an ipod touch. Apple tv would disappear randomly. Any airport express speakers would individually disappear randomly. Nothing fixed it with any consistency. I eventually got rid of the ipod touch because I couldn't justify a $400 remote control that only worked part of the time (and had to be on the charger more than I actually got to use it) .
  25. ascender macrumors 68000

    Dec 8, 2005
    Something I found suggested on the Apple forums was to make sure the machine hosting your library and the ATVs are all on the same sort of connection - i.e. all wireless or all wired. I had a mix here and since changing the ATVs to both be wireless, I've yet to have the error reoccur.

    My Mac Mini hosting iTunes is still wired and I notice some of you were having the problem with multiple ATVs all wireless, so that doesn't help you, but it does seem to have worked for me.

Share This Page