ATV 2 won't update

Discussion in 'Apple TV and Home Theater' started by HipHopTrex, Sep 26, 2013.

  1. HipHopTrex macrumors member

    Mar 9, 2012
    First off let me say it's jailbroken and at around 4.4.3? I think? Perhaps something like that. (I'm asking here because my thread on firecore got no responses)

    I went to try and update it via seasonpass and seasonpass wouldn't detect it when I plugged it in. Tried iTunes as well and it wouldn't read it. So then I said ah screw it and tried updating, but I can't even update the jailbreak I have under the maintenance tab. Then I tried to update to the latest OS, and it just tells me I'm up to date?:confused: And then finally I tried factory reset as well under the settings and still no cigar. Says it can't be restored right now and to try again later.

    Honestly, I'm lost. And since I switched macbooks I lost my shsh blobs as well.

    Thanks for any suggestions you guys can offer.
  2. donrsd macrumors 6502


    Dec 16, 2011
    South Florida
    double post


    You cant restore or upgrade via the Apple TV.

    You HAVE TO connect to iTunes & restore.....which will give you the latest software & thus lose your jailbreak.

    Check your PM
  3. HipHopTrex thread starter macrumors member

    Mar 9, 2012
    The problem is that neither my MacBook Air, an older pro, or hell even an old PC can detect when it's connected. Nothing pops up in iTunes at all. Absolutely nothing.

Share This Page