ATV 4 crashes

jwolf6589

macrumors 68000
Original poster
Dec 15, 2010
1,895
295
Colorado
I have had it for almost a week and its already crashed twice. Anyway to get rid of these crashes?
 

vertical smile

macrumors 601
Sep 23, 2014
4,624
5,717
I have had it for almost a week and its already crashed twice. Anyway to get rid of these crashes?
I warned you in another thread that the ATV4 has lag, slowdowns, and app crashing issues. I suggested getting an ATV4k instead.

What tvOS are you using?

Are you still on tvOS 11? If so, I would stay there. tvOS 12 seems a little more sluggish than usual on my ATV4. Maybe wait to see if the next patch speeds things up.

If you are on tvOS12, then just wait it out. Hopefully it will get better.

You are coming from an ATV3 right? There is a big adjustment when going from the almost perfect ATV3 apps to the crappy tvOS version of apps, so I bet the crashing just makes things worse.

Maybe return the ATV4 and get an ATV4K.....
 

techwarrior

macrumors 65816
Jul 30, 2009
1,191
448
Colorado
Is it crashing on its own, or when a certain app is running?

I have had 2 ATV4 since they first came out, on tvOS12 now, and don't recall ever having them crash. I have had some apps that crash, and I typically reinstall these apps. Also, a reboot before reinstalling might be a good idea, a power off restart to make sure everything from the old app is cleared.

On ATV3, all apps probably went through more scrutiny from apple given no app store. but with ATV4 and later, devs submit apps for review and pressure is on apple to approve. So, chances are more sloppiness gets through.
 

jwolf6589

macrumors 68000
Original poster
Dec 15, 2010
1,895
295
Colorado
Is it crashing on its own, or when a certain app is running?

I have had 2 ATV4 since they first came out, on tvOS12 now, and don't recall ever having them crash. I have had some apps that crash, and I typically reinstall these apps. Also, a reboot before reinstalling might be a good idea, a power off restart to make sure everything from the old app is cleared.

On ATV3, all apps probably went through more scrutiny from apple given no app store. but with ATV4 and later, devs submit apps for review and pressure is on apple to approve. So, chances are more sloppiness gets through.
Is it crashing on its own, or when a certain app is running?

I have had 2 ATV4 since they first came out, on tvOS12 now, and don't recall ever having them crash. I have had some apps that crash, and I typically reinstall these apps. Also, a reboot before reinstalling might be a good idea, a power off restart to make sure everything from the old app is cleared.

On ATV3, all apps probably went through more scrutiny from apple given no app store. but with ATV4 and later, devs submit apps for review and pressure is on apple to approve. So, chances are more sloppiness gets through.
It seems like its Netflix. I mean technically it did not crash, but Netflix was not working correctly so I had to reboot the ATV to get it to work correctly.
[doublepost=1537776238][/doublepost]
I warned you in another thread that the ATV4 has lag, slowdowns, and app crashing issues. I suggested getting an ATV4k instead.

What tvOS are you using?

Are you still on tvOS 11? If so, I would stay there. tvOS 12 seems a little more sluggish than usual on my ATV4. Maybe wait to see if the next patch speeds things up.

If you are on tvOS12, then just wait it out. Hopefully it will get better.

You are coming from an ATV3 right? There is a big adjustment when going from the almost perfect ATV3 apps to the crappy tvOS version of apps, so I bet the crashing just makes things worse.

Maybe return the ATV4 and get an ATV4K.....
TV OS 12.0. I have not experienced any lag or slowdowns, just apps like Netflix giving me issues.
 

techwarrior

macrumors 65816
Jul 30, 2009
1,191
448
Colorado
Have you tried re-installing Netflix?

Uninstall it, reboot (unplug the power cable to get a clean boot), then install Netflix again.
 

vertical smile

macrumors 601
Sep 23, 2014
4,624
5,717
It seems like its Netflix. I mean technically it did not crash, but Netflix was not working correctly so I had to reboot the ATV to get it to work correctly.
Can you describe the issue? Usually logging out, then back in fixes a lot of issues. If not, then try deleting and reinstalling.

I have had glitchy issues with Netflix on my ATV4 since the launch. Actually, I have stopped using it on my ATV4, and just started using my TV's built in Netflix app.

The glitch that happens most only affects the main profile on Netflix, which happens to be mine. Basically, I cannot go on my own profile, it will take me to someone else's when click on mine. Logging out, and logging back fixes this issues 100% of the time, but it is just annoying.

Another glitch, somewhat related to the first one, is that sometimes Netflix will show watched content from one profile on another. This happens less often, and usually fixes itself after a day or two.

I much rather use the ATV3 version of Netflix and I do. I never have these bugs with Netflix on there. Actually, I watch the ATV3 version a lot more often than the tvOS version.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.