ATV 4K and Homekit

Discussion in 'Apple TV and Home Theater' started by BuddyRich, Oct 14, 2017.

  1. BuddyRich macrumors member

    BuddyRich

    Joined:
    Mar 21, 2012
    #1
    Not sure what went wrong but Homekit is not working on my ATV 4K. It was initially and now I can't get it back.

    On my iPad I can fully control my homekit devices via Siri. Ive got TFA on and am using the same icloud account on both iPad and ATV. I see the ATV device under devices in the icloud settings on the ipad.

    However Siri on tvOS says nothing is connected.

    Upon first setup it was all working well, but I think I updated the Hue app and since then it only worked with some things. It lost track of rooms. So while I could say turn off all lights, it would work, I couldn't say turn off basement lights. Or turn of "specific" light. I had an outlet, and could say turn on/off amplifier and it understood "whats my temperature" from the ecobee, but I couldn't get it to give me the basement temperature from the sensor there.

    Ive tried logging out of icloud on atv and ipad (much more of a pain to do on the ipad). I did a reset of the atv and I am just not seeing homekit under icloud settings on tvos.
     
  2. Hoek_NL macrumors newbie

    Hoek_NL

    Joined:
    Jan 12, 2017
    Location:
    Almere Netherlands
    #2
    Hey BuddyRich, seems you've done all there is to do, did you get it solved in the end?

    I've got a pretty nice setup right now, atv 4k as hub, with both Hue bulbs and dimmers and non-homekit switches working via Homebridge (software, running on mac mini server at the mo.).
    All is working fine, also via Siri, but yesterday, one of the Hue dimmer switches, which is configured via Homekit, no via Hue hub, stopped working. Had a few scenes setup on it, which is a cool function, doesnt have to be on/off/dimm.

    Weird thing was, on iphone home app, the dimmer was there and active, responding icon when buttons pressed, but non of the configured scenes were activated. removed and added scenes, no joy. After rebooting atv, all well again.

    Have to say, i have this with multiple 'smart' appliances, like receiver etc, they need a frequent reboot.

    Hope you got it running again.
     

Share This Page