aTV Flash help --Anyone else having problems?

Discussion in 'Apple TV and Home Theater' started by dareiff, Jun 5, 2008.

  1. dareiff macrumors newbie

    May 19, 2008
    So after listening to this weeks Macbreak Weekly, I decided not to wait any longer to try out ATV Flash.

    Well, it gets through the bootloader screen (loading up a small linux distro and 'adding' things to the box) but because I have a widescreen tv, or perhaps because my Vizio isn't that good at converting the AppleTVs signal that well BEFORE it boots completely, I can't tell whether or not the thing is actually done.

    I've restarted once it stops, but it always reverts back to the system restored state.

    I'm getting VERY mad at Apple Core LLC., and just about ready to cancel my paypal payment.

    Anyone else having problems?
  2. tom1971 macrumors 6502a

    May 15, 2007
  3. randyegan macrumors newbie

    Jun 5, 2008
    ATV Flash not working

    Yes, I too am having problems installing ATV Flash. In fact it has pretty much bricked my Apple TV. It keeps flashing back & forth to the Apple TV logo and menu. It seems like it is rebooting. Somehow ATV Flash has corrupted my network settings, because when I take the ethernet out of the Apple TV, the cycling flashing stops and I can use the menus, but I don't have network control.
    Factory restore does not fix the problem. It seems the bootloader has been modified by ATV Flash and is not restorable.

    Users, careful using software... I would wait.

    I am waiting patiently from Apple Core, LLC to help me fix my bricked Apple TV.

  4. omni macrumors 6502

    Jan 20, 2008
    For what it's worth - I orderd an AppleTV Flash as well. Mine worked as advertised with no hassles what so ever. I just followed the instructions that were on the printout and had no problems.

    Good luck though!
  5. baronbuzby macrumors regular


    May 23, 2006
    Maidenhead, UK
    I wish I'd read this earlier.

    My apple tv is constantly switching between the logo and the atv flash menu. How do I fix it anyone??

    randyegan - have you heard anything yet???
  6. tom1971 macrumors 6502a

    May 15, 2007
    Did you try a factory restore?
  7. baronbuzby macrumors regular


    May 23, 2006
    Maidenhead, UK
  8. tom1971 macrumors 6502a

    May 15, 2007
    Press and hold '-' and 'Menu' button.
    That should do it.
  9. baronbuzby macrumors regular


    May 23, 2006
    Maidenhead, UK
    Thanks Tom1971 - I managed after about 15 reboots to do a factory reset, but it now cycles between the apple logo and the original apple tv menu.

    Also after rebooting it constantly gives me an itune code, then an apple logo, then a different code, and so on every 2 seconds or so. I have now done a factory reset twice.

    I am really hacked off as I love my apple tv, and it was only after listening to macbreak today, I thought I would give it a go!

    I've emailed applecore llc, but not sure what they can do, apart from give me my money back, but I still have a broken apple tv.
  10. i.Feature macrumors 6502


    Apr 11, 2005
    Montreal, Canada
    how does aTV Flash get it's content? Does it link to itunes? or do you set up other folders?
  11. baronbuzby macrumors regular


    May 23, 2006
    Maidenhead, UK
  12. tom1971 macrumors 6502a

    May 15, 2007
    No, they install other plugins that allow you to access files without having to sync through Tunes.
    Of course you can still use iTunes.
  13. NibbleDapple macrumors newbie

    Jun 6, 2008
    I have struggled with some of the same issues that others have had for the past 2 days, trying to create the aTV Flash v3 patchstick seemed so simple. Follow the short instruction & done. But after testing a couple of flash drives I was not successful. At first I followed the lenghty tutorial on iClarified & it worked, but not being satisfied with few apps (my mistake) I went for the aTV Flash. I had the same problem with the aTV switching back & forth between the menu & logo. I was able to solve the problem by using another internet connection & reset to factory then software update. Now I'm back with a 2.02 non-moded atv & have emailed Apple Core for a resolution. Will update as to what happens...
  14. dareiff thread starter macrumors newbie

    May 19, 2008

    Just getting back from a two-day trip.. I've tried a few times to get ahold of the 'developer'. (His aim name is applecorellc247)

    Anyway, still having the same problems. I'm beginning to think maybe your 'net access has something to do with it..

    Since this appears to be a common problem, hopefully it'll be an easy answer.
  15. jarmoni macrumors newbie

    Jun 8, 2008
    Espoo, Finland
    If your aTV flash installation stops without last confirmation message the problem is on your flash drive. It happens me too and after few unsuccesful installation I made new flash drive for different memory stick and then installation runs smoothly to the end.
    Looping problem has nothing to do with aTV flash. It's known problem when apple-TV has configured to get address using DHCP. It's better to use static IP-address if possible.
  16. baronbuzby macrumors regular


    May 23, 2006
    Maidenhead, UK
    I think I have the answer~!

    Disable itunes on all computers - including itunes helper on any Pcs
    Factory reset
    Upgrade to 2.02
    Put in patchstick then reboot

  17. brando24 macrumors newbie

    Apr 28, 2005
    I can't even get as far as to get to Version 2 software on my appletv at this time. I have done a restore at least a half dozen times as well. I even tried reinstalling the patchstick and then doing a restore after that to see if the looping problem would subside. has anyone had anymore luck with contacting this guy or getting it to work enough to install 2.0 on their appletv?

    Ok, I think it is working (in relation to the previous post about a fix). The only other thing I would add to that post is that a direct ethernet connection (bypassing Wi-Fi) to update to 2.0 is a key to this process (at least to fixing my appletv anyhow). hope this helps everyone fix theirs.
  18. crotalus99 macrumors regular

    Dec 4, 2007
    I did mine the other night. I made a patchstick with an old 256mb drive and the aTV wouldn't recognize it. I then did a restore of the aTV because they now say that you don't have to and turned off iTunes on the server and still no luck.
    I made a new patchstick with a Sony 1Gb stick that I got at Target the other day for $9 and it worked flawlessly.

    I think that the problem that people are having is with the brand or type of stick that they are using. My first stick created perfectly and wouldn't work at all.

    My suggestion would be to get a different USB stick and try again.

    I do not think network access should matter at all, because everything being done is on the stick. In my situation, after I restored I didn't even establish a connection with the network prior to patching.

    Hope this helps someone.
  19. Timan macrumors member


    Dec 1, 2003
    I have a question... I successfully used that aTVFlash3 (usb thingy), and I was wondering is there a way to restore the AppleTV to its original state? Would resetting the appletv to factory defaults do the job? Or is it more complicated than that.
  20. tom1971 macrumors 6502a

    May 15, 2007
    No, just do a factory restore and you are back to square 1.
  21. DaveWonders macrumors regular

    Sep 12, 2006
    I was a bit hesitant to spend the $50 when people said they had problems. However I took the plunge and it worked first try with no problems. Used an Intel Mac 10.5 to make the patchstick which was actually a 1 GB SD card plugged into a USB card reader. I have a question about Sapphire though:

    I've imported all of my TV Shows successfully and the episode names were fetched correctly. However, only about 10-20% of my shows have any screen caps, and those that do are on the episode screens...What I mean is when I drill down in Sapphire to a show, then a season, some episodes have a corresponding picture or screen cap, but when I'm browsing between different shows, there is no artwork, just color bars. I read through the FAQ on Sapphire's page but the only thing I could find was the drive needs to be readable and writable since the program saves the artwork and info as a file in the folder. First I don't know how to do that, and second since some shows DO have artwork and info, doesn't that rule that out as the problem? The shows I have are popular, like Curb your Enthusiasm, Lost, Heroes, etc...nothing obscure.

    Anyway, anyone hesitant about the problems with AppleCore, all I can is I had none.
  22. Casablanca macrumors newbie

    Jun 23, 2008
    Installed OK...a few problems using it

    Using aTV Flash v3.0, and a 1gb USB thumb drive, I managed to install everything OK. This was with a brand new 160gb Apple TV device.

    However I've noticed the performance is a bit patchy. I download most of my content via BitTorrent (so, mostly .avi / DivX files), and so far everything has worked, EXCEPT each time I open a file, it's all a bit strange....the Apple logo comes and goes, and / or it says "please wait" while I can hear the audio has started in the background, and / or it throws me back to the main menu. When I persevere, it works eventually, often on the 2nd, 3rd or 4th try. This problem still persists. Weird.

    Another odd thing, I watched a TV episode where the picture quality was poor (as though it had been badly encoded). But it improved during the show, and then when I watched it again, it was greatly improved, almost as though it had learned how to decode the program better! Obviously this is irregular, I'm just trying to describe the behaviour as it seemed at the time. This only happened the first time I used it.

    Anyway, on the whole, I'm happy with the aTV Flash v3.0, although I'm hopeful that a future patch will clean up these issues.

    All other functionality remains unaffected, and I haven't played around with the other functionality as yet (such as the browser), as I don't really have a need.
    Apple TV version 2.0
    iMac G5 2gb RAM
    BT HomeHub
  23. MysterMac macrumors member

    Sep 12, 2007
    SSH works but cant write files

    refurbished ATV 160gb with v1.1 sw, updated to 2.02, patchstick made with 512mb sd card in usb card-reader ( downloaded from bit-torrent). All done in 5 minutes without a hitch.

    SSH however, I can get in, but cant write files. I can make folders, just not write the avi's Im dragging and dropping in FUGU.
  24. ayale99 macrumors 6502

    Dec 6, 2007
    Finally got mine working. I too had to make a second flash patchstick. The AppleTv didn't like the SanDisk I used the first time. Everything works fine except the Flash player in Couchsurfer.

    Anybody else having that problem? Is the necessary flash player framework included in the Patchstick or do you manually have to install it via Fugu SFTP?
    It appears that the plug-in files are already on the AppleTV but I still get the little blue box popping up in Hulu.:confused:
  25. applecorellc macrumors newbie

    Jun 27, 2008

Share This Page