ATV Loader, Flash

Discussion in 'Apple TV and Home Theater' started by Commander Tagga, May 5, 2008.

  1. Commander Tagga macrumors newbie

    Joined:
    May 5, 2008
    #1
    Greetings All, newbie here.

    I spent much of the weekend coming up to speed on hacking my new Apple TV (really new, Take 2, software update run). Following the tutorials at iClarified, I created an ssh patchstick for my unit, got ssh enabled, and successfully installed Couch Surfer, Sapphire, and ATV Files. I impressed myself.

    Following the same methods (actually, trying two different methods), I attempted to install ATV Loader. I both tried directly placing the AwkwardTV.frappliances folder into the proper directory. Upon reboot, there was no AwkwardTV in the frontrow menu. So, I deleted, and tried using terminal to run the installer. I got an "installation successful" message, but again, upon reboot, no AwkwardTV in the menu. Does anyone have any advice on that?

    Also, when I use Couch Surfer to navigate to Hulu, I get a message that Flash 9 is needed. I'm not so advanced as I know how to do that. Can anyone point me in the right direction for a tutorial? I installed the perian codecs for DivX, but I don't know what to do about Flash.

    Finally, it appears that the only way to play DivX files is to use Fugu to directly transfer them to the Apple TV... no way to stream. Am I right, or am I missing something?

    Any help would be MOST appreciated.
     
  2. Commander Tagga thread starter macrumors newbie

    Joined:
    May 5, 2008
    #2
    Okay, got an answer to the Flash problem on another board, got that working fine, but still no idea how to proceed with ATV Loader and nitoTV.

    Any assistance would be appreciated.

    Apple TV Take 2, 2.0.2
     
  3. TuckBodi macrumors 6502

    Joined:
    Jan 10, 2007
    #3
    I believe ATV Loader is an old plugin going back to even ATV 1.0 and hasn't been updated in quite some time. Installing plugins are usually pretty straightforward though as you just use Fugu to copy the frappliance to the frontrow home directory and using Terminal do a sudo to move it from the home directory to the plugins directory like so:

    1) Make sure it is writable before you do so though by:
    sudo mount -uw /

    2) Move the plugin:
    sudo mv Sapphire.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    3) Reboot
    sudo reboot

    Login/Password for all ATV's is: frontrow/frontrow

    Streaming - yes you can stream by mounting your remote drive through AFP/SMB/NFS. There's a bunch of info up on the AwkwardTV forums (forum.awkwardtv.org) and of course on the wiki itself.
     
  4. Commander Tagga thread starter macrumors newbie

    Joined:
    May 5, 2008
    #4
    Tuck, thanks... yes, I'd been using that method to load plugins. I just didn't realize that ATV Loader was now obsolete. Thanks for the info, and for the heads up on the guide to streaming DivX. That looks like quite the project!

    Thanks again!
     
  5. DeuceDeuce macrumors 6502a

    DeuceDeuce

    Joined:
    Aug 8, 2007
    Location:
    San Dimas, CA
    #5
    How did you install couch surfer?
     

Share This Page