ATV missing from iTunes

Discussion in 'Apple TV and Home Theater' started by TomP80, Nov 1, 2009.

  1. TomP80 macrumors member

    Joined:
    Apr 15, 2008
    #1
    Apologies if this has already been answered, but I have genuinely looked for an answer in this forum and others and haven't found one.

    Anyway, I have just moved house, and have gone from having both my PC and ATV wirelessly connected at the old place (no problems), to having my PC connected to my router via ethernet, and ATV connected wirelessly.

    When i run iTunes, the ATV cannot be detected.

    If I run an ethernet cable and connect the ATV to the router via ethernet, there are no problems - it is instantly recognised in iTunes and can sync and stream without any problems.

    The ATV is definately connected to the wireless network properly (i can download online contect from the iTunes store), it just can't been seen in iTunes.

    Are there any known issues with a wirelessly connected ATV, ethernet connected Windows PC setup? My wife is getting a little angry about a 10 meter ethernet cable running across our floor :)

    My router is a Dlink DSL-504g if that helps.
     
  2. jaw04005 macrumors 601

    jaw04005

    Joined:
    Aug 19, 2003
    Location:
    AR
    #2
    This is a common problem.

    1. Make sure all your iTunes Store content is synced back to your PC/Mac from the Apple TV.

    2. Perform a factory restore on the device, then re-upgrade to 3.0.

    3. Re-setup the device in iTunes.

    This usually fixes the problem.
     
  3. TomP80 thread starter macrumors member

    Joined:
    Apr 15, 2008
    #3
    Didn't work unfortunately.

    I did a factory restore, and iTunes recognised the ATV immediately. However after the connection code is entered, the ATV dissapears from the iTunes device list and does not come back.

    It works perfectly if you plug it in via ethernet.
     
  4. TonD macrumors newbie

    Joined:
    Jul 14, 2009
    Location:
    Europe
    #4
    I've had similar problems, but my situation was exactly opposite. When I moved, I switched from having my PC connected thru Ethernet and my ATV connected via WIFI to a situation where both are connected thru wifi.

    In both occasions I've had the ATV mysteriously disappear (and re-appear!) in iTunes every now and then. I've noticed that when the ATV is playing content it disappears!

    So far I've noticed that the "it just works" Apple mantra is less true when you combine it with Windows. For instance I had to boot into my Leopard HackPro to configure my AirPort Express, and also noticed that the ATV wasn't missing from iTunes ever.

    So far I've found no solution, so I'll follow this thread ;)
     
  5. Itogator macrumors member

    Joined:
    Jul 16, 2008
    #5
    I had a similar issue and went as far as having apple replace my apple tv. I won't bore you with all the steps I had to go through, but the problem is now fixed. Here is how I fixed it:
    I finally got a phone support guy at apple who knows what he is doing. It turned out it was a firewall issue. I don't mean my apple firewall but rather a secondary firewall. It turns out my netgear firewall was blocking apple tv. I removed it from the block list and apple tv has had zero problems for over a month! I hope this helps.
     

Share This Page