ATV no longer wakes up iTunes after Mavericks

Discussion in 'Apple TV and Home Theater' started by Richard8655, Oct 26, 2013.

  1. Richard8655 macrumors 6502

    Joined:
    Mar 11, 2009
    Location:
    Chicago suburbs
    #1
    Just wanted to share my experience with ATV no longer waking up my Mac to access the iTunes library, after upgrading to Mavericks. I went directly from Snow Leopard. This is for anyone else who might have had this problem.

    After ensuring iTunes Home Sharing is turned on, Bonjour proxy enabled, Mac wifi turned on with my network identified, and Energy Saver set to "wake for network access", still no success.

    What seemed to finally fix it was an Airport Utility change. Under Internet Options, changing Configure IPv6 from "link-local only" to "Automatically" seemed to do it. Then restarted Airport Extreme.

    I may be wrong and it could have been a fluke with something else having been changed, but this is the last change that seemed to fix the issue.
     
  2. swhit macrumors newbie

    Joined:
    Mar 3, 2008
    #2
    I have the same problem with waking my iMac using ATV3 over a home wifi network. I can't get wake from network to work. I have an old iMac (2007, I think). Wake from network was fine using 10.8, but with the upgrade to Maverick's, it no longer works. Drives me nuts.

    I tried changing settings on the airport extreme that is used for my home network, but nothing seemed to work.

    Any one else with this problem. Any fixes?

    Thanks.
     
  3. mcadale macrumors newbie

    Joined:
    Feb 17, 2013
    #3
    Yes, same here.

    ATV2 and iMac late 2012 now running Mavericks.
     
  4. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #4
    Strange, works for me.
    You could try from command line:
    Code:
    sudo pmset -a womp 1
    See also: pmset command synopsis
     
  5. melbri macrumors member

    Joined:
    Sep 14, 2008
    #5
    Same here. The connection between my ATV3 and iTunes is lost after inactivity, even if my computer is awake. I need to turn off home sharing and turn it on again, sometimes have to reboot iTunes.
     
  6. Flat Six macrumors newbie

    Joined:
    Jul 14, 2012
    #6
    Try restarting the ATV (settings, general, restart). At least you can do this from your couch. :) Seriously, this worked for me. After upgrading to Maverick the ATV couldn't find the library of the computer, it was spinning and spinning without result. Problem disapeared after restarting the ATV, problem came back once or twice, but lately I don't have this problem at all.
     
  7. swhit macrumors newbie

    Joined:
    Mar 3, 2008
    #7

    That seemed to work for me (i.e., the terminal command). Thanks!
     
  8. sim667 macrumors 65816

    Joined:
    Dec 7, 2010
    #8
    Does anyone know if that command line works for other applications?

    I used to use WOL for plex, but it hasnt worked since I changed to mavericks.
     
  9. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #9
    Power Management settings are systemwide - i.e. work for all apps.
     
  10. osohardy macrumors member

    Joined:
    Jul 7, 2009
    #10
    I've also had issues after updating my Mac mini 2009 from snow to mavericks and my 2009 imac from ML to mavericks. Basically on both wake on demand no longer works over Ethernet, which I had been using for years hard wired. Over wifi it does work. I've done numerous checks, reboots, and resets, resetting flags with pmset, setting darkwake flags etc and they don't work. I confirmed with bonjour browser the services are there. What I've concluded by looking at mdnsresponder is that I believe it thinks my Ethernet no longer supports womp. If you run this command and grep in syslog for womp after sleeping/waking

    sudo killall -USR1 mDNSResponder

    I find it says "no womp" for Ethernet, and "supports womp" for wifi.

    I'm kinda pissed something this fundamental was broken. I haven't tried changing the ipv6 on my airport from "link local" cause frankly I don't know what that means...but I'll try it.
     
  11. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #11
    Do you think this has something to do with Mavericks aggressive power saving feature?
     

Share This Page