ATV: the enjoyment & frustration

Discussion in 'Apple TV and Home Theater' started by JMEANS, May 12, 2013.

  1. JMEANS, May 12, 2013
    Last edited: May 12, 2013

    JMEANS macrumors regular

    Jun 9, 2012
    use to love my ATV's and all they had to offer to now utter frustration. it seems like every ATV update there arises more performance hiccups & changes than before. One main one for me has occurred with both my ATV2 & ATV3 and it revolves around simply viewing trailers!
    I use both WiFi and Ethernet between the two pucks and when I try to simply view a trailer on either it takes forever to load, when originally (a few updates back ) it would perform as follows:

    click on trailer and within 20 seconds it would load up a quarter of the bar and start playing, NOW it waits until the trailer has loaded to MORE THAN HALF of the bar to finally start?! this is something totally new and it happens on ATV2 & 3. and my internet provider and hardwire/software has not changed at all.

    It is so frustrating that something that use to work with only a couple stalls now and then is now standard operation procedure?! I use to love viewing HD trailers all the time and now choose not to because i don't have the time it takes to watch them or slip into a bad mood quick!

    Another bad wifi example is with my ATV3 in the same room as my router with a 10 gig file that will not progressively load as it plays and will come to a stop?! this is crazy that once a movie has started via wifi that it will only load and play to a point then pause and take forever to play again and only for another few minutes?! that is such garbage in my book, when it plays thru fine when hardwired!

    Anyway ... Has anyone else experienced a performance change similar to this at no fault or change of your own other than updating your puck?

  2. mic j macrumors 68030

    Mar 15, 2012
  3. pavelbure macrumors 6502a

    Feb 22, 2007
    No, but the Hulu app used to tell me how many seconds the commercial break would be, now it just shows some circle like the iTunes preview circle.
  4. Hammerofthegods macrumors newbie

    Sep 21, 2011
    I used to have no problems with Apple TV either (gen 1 and 2) but with "time (Mac OS upgrades, Apple TV OS, etc) it started having "similar" problems. My solution - get a apple airport express router. Long story short, routers tend to have issues with Bonjour, and over time the number of issues / severity increases as the os updates but the router becomes stagnant.

    Once I bought the router and switched it out all my issues went away...
  5. JMEANS thread starter macrumors regular

    Jun 9, 2012
    Thank you very much! I had figured as much with the router. I have had the same Bell wifi router for about 3 years now and would love to upgrade but Bell is telling me this is the fastest support they have in my area? From my understanding I thought you couldn't get an outside router because Bell routers are locked or whatever? Anyway that might be a separate thread to start all together lol or if anyone could enlighten me on the router thing it would be much appreciated. All I can tell you that I know is that I do not have N router capability in my area yet. Still using a G router. Thanks
  6. HobeSoundDarryl macrumors 604


    Feb 8, 2004
    Hobe Sound, FL (20 miles north of Palm Beach)
    I'm increasingly convinced that :apple:TV has some kind of memory leak bug. I know the general perception around here is that it's always the non-Apple links in the chain but when this kind of thing is happening on my :apple:TV (whether it's stuff- like trailers- streaming from distant server or content stored internally on my own hard drive), I find the magical solution is to fully unplug the :apple:TV, wait 30+ seconds, plug it back in and try again. Inevitably, the problematic video I was just trying to watch will now play as we all remember it can be on :apple:TV.

    The next time you get frustrated over playback issues along these lines, try this simple trick and see if it works for you. Just about every time, this solves that kind of problem for me.
  7. JMEANS thread starter macrumors regular

    Jun 9, 2012
    Thanks Hobs... But i think this is a router thing. I had a wired ATV2 for almost 2 years with countless updates etc thru Apple and noticed the decline in performance in the last 6 months. I have not noticed any decline in my wired Mac Pro ever. I then decided to sell my ATV2 (I have no desire to jail break) and with that $ I bought 2 new ATV3's. One i put wired in place of the ATV2 and the other ATV3 I setup wireless in a room very close to the existing router and noticed the lacking performance on both as well out of the box! Actually the wifi puck wouldn't even progressively load as it played a 10 gig movie?! So I think it's time to ditch the Modem/Router provided by Bell and try a separate router. At least I am hoping I will see an improvement...
  8. HobeSoundDarryl macrumors 604


    Feb 8, 2004
    Hobe Sound, FL (20 miles north of Palm Beach)
    Could be. BUT, I have AEBS as my router. Same things happen. I have cat5e runs and very fast Comcast broadband. The only variable that I change when those same things occur is what I described... and then it "just works" again.

    Sure, it's possible you've got other problems in your chain. But you can test my solution for free or you can take the "blame anything & everything that is not Apple" suggestions and spend a lot of money to maybe solve the problem or maybe still have it.

    In wired vs. wireless, wired will almost always win. Wireless can lay claim to even higher theoretical speeds but getting the theory in reality is rare. I simply think the "3" has some software bugs and, because it's a "hobby", they just persist for much longer than other, more favored Apple hardware. I'm feeling increasingly confident about this memory leak bug and I've read plenty about others having problems with wifi vs. wired connections.
  9. Bozley0621 macrumors 6502

    Mar 25, 2009
    I have experienced the same issues when watching iTunes move trailers and trailers for movies in theaters.
  10. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    I hardwire all stationary devices including XBOX 360 & ATVs (both are 10/100) and everything is fast and flawless on Rogers cable.

    I recall an ATV hiccup once from a firmware update, a simple restore solved that.
  11. JMEANS thread starter macrumors regular

    Jun 9, 2012
    Interesting to hear, I assume your in Canada with Rogers - I'm a Bell customer in Ontario and the service is declining unfortunately...

    As far the unplug thing, I hear ya and have tried that in past with another issue and didn't resolve anything... The fact that BOTH of the ATV3's are brand new out the box and had the same performance lag as my 2 year old ATV2 on initial setup doesn't justify an unplug situation.

    Thanks for the advice everyone, I may try the new router thing and if I don't notice a difference I will just return it. However if there ate any other suggestions I would surely welcome them : )


    Are you wifi or Ethernet? Do you use a seperate router or is it a modem mix? Thanks
  12. Menel macrumors 603


    Aug 4, 2011
    Yes and no. ATV2, fully updated. 720P is fine enough for me, not picky.

    Netflix and Hulu have flawless performance.

    Rented Ghostbusters 2 last weekend, flawless performance.

    I stream DLNA media from my PC, PS3MediaServer (AcePlayer iPhone/iPad app). ~500MB TopGear eps, some movies 1.5-2GB. Doubt I've tried anything larger. Flawless.

    Movie Trailers sometimes hiccup. It's like bandwidth is lacking for these. An increased load time before playing is going to be based on transfer rate. It wants to have enough of the video cached, so that your connection (it could be Apple's end, not yours), enough video cached so that you don't run into a pause and wait to catch up scenario and the trailer can play straight through.
  13. JMEANS, May 15, 2013
    Last edited: May 15, 2013

    JMEANS thread starter macrumors regular

    Jun 9, 2012
    The trailers are probably the best judge of my decreased level of performance overall. 2 years ago a trailer would load about a quarter of the bar then play and progressively load and never stall. It's key that it used to progressively load when playing! Now it won't even start until its loaded over half the bar. Takes forever to even begin?!
  14. westrock2000 macrumors 6502a

    Oct 18, 2013
    Does the Bell router have an administration webpage you can log into? If so you can always turn off the wireless and even the DHCP (IP address assignment).

    Then have another router upstream that does all that stuff and connect one CAT5 from the new router to the Bell router. That's where your Internet access will come from. Everything else within the local network will occur over the new router.

    The way I have my house setup is I use the ISP provided router to use DHCP, to assign all devices IP addresses. Upstream from that I have a gigabit switch that all the Ethernet wires plug into, and one wire going from that switch to the ISP provided router. Each device only needs to get its IP address from that router, and then it's free to communicate through the gigabit switch with other devices. I also have 3 wifi routers plugged into the switch that provide wifi, but do not provide DHCP.
  15. tlegein93 macrumors newbie

    Oct 16, 2013
    apple tv 2 problems

    i have been using my jailbroken atv2 on season pass until it deleted all other apps except xbmc, settings, and computers. i plugged it into my computer and restored it through iTunes and the same thing happened on the tv again. it will not connect to internet when it said activating it just never happened i tried restarting my router and everything. if someone could please lend me a hand thank you very much:).

Share This Page