ATV2 and Netflix Aspect Ratio Problem

Discussion in 'Apple TV and Home Theater' started by MacBird, Dec 18, 2010.

  1. MacBird, Dec 18, 2010
    Last edited: Dec 18, 2010

    MacBird macrumors 6502

    Joined:
    Apr 1, 2010
    #1
    I bought the new Apple TV and tried to watch a foreign film on Netflix. I use a widescreen Sharp HDTV and it streams at 720p but there is no way to change the aspect ratio since the only option is 'stretch'. This way it clips half of the subtitles. When I watch the same film using Netflix streaming on my MBP the aspect ratio and subtitles look fine.

    Is there a way to fix this? If not, I will probably just return it.
     
  2. BigBrocktoon macrumors newbie

    Joined:
    May 2, 2010
    #2
    Return your TV? or the ATV? Not sure either is at fault, the movie should just show up mildly letterboxed if it is naively outside of perfect 16:9. I don't see any reason to stretch HD content. Why you are seeing something else on your MBP is anyone's guess, unless the letterboxing is less obvious.

    Be careful if it is an older set. I was trying to troubleshoot all sorts of problems for my mom over the phone. Turns out she had an LG "HD Capable" plasma, but the panel was in no known HD resolution. This caused all sorts of aspect ratio issues for her. I just upgraded her to a 55" Sony 3D. Now all is well.
     
  3. MacBird thread starter macrumors 6502

    Joined:
    Apr 1, 2010
    #3
    Thanks, the TV works well with my HDMI DVD player. I can change the aspect ratio to prevent stretching with that combination. It seems that the ATV stretches movies to prevent black bars left and right and clips a bit off the top and bottom to keep the aspect ratio correct. Subtitles are often taking up some of the black bar on the bottom, especially if there are two lines of text. The Netflix website just shows the movie unclipped and in doubt there are black bars which is fine with me.

    For fun I checked an old film that has a 4:3 format. In that case the ATV does not stretch it all the way but still clips a bit off top and bottom.
     
  4. Ritsuka macrumors 6502a

    Joined:
    Sep 3, 2006
    #4
    Maybe you should check if your tv has an option to disable the overscan.
     
  5. MacBird thread starter macrumors 6502

    Joined:
    Apr 1, 2010
    #5
    Thanks, I don't think it does. BTW, it is a Sharp Aquos.
     
  6. BigBrocktoon macrumors newbie

    Joined:
    May 2, 2010
    #6
    Dude is right when he says turn off the overscan, if you can. Two hints that will help you get your head around this problem is first, your DVD player is not HD, and is natively 4:3, as you know. When you watch a "widescreen" DVD you can zoom or stretch, and have it fill more of a 16:9 screen, which you also seem to understand.

    Second, most films are natively filmed with Panavision which is about 2.2:1. If the foreign film you are watching is a full frame print (which I think is what is going on), the 2.2:1 frame must be letterboxed to fit in a 16:9 screen. That is how it should look. Zooming or stretching is not needed, it is meant to be viewed in it's native ratio, hence it is chopping your subtitles when you zoom. A lot of 16:9 prints are Pan&Scan, which fills the whole frame. In my experience, most art films are not. Nothing is wrong with the ATV, or the content, it is just not meant to be stretched.

    This is different than HDTV, which is usually shot in 720p 16:9 in it's native form.
     
  7. MacBird thread starter macrumors 6502

    Joined:
    Apr 1, 2010
    #7
    Thank you for the explanation, which makes sense to me. It seems then that my TV is not a good combination with the ATV since I can't disable overscan. There is only an option to adjust the horizontal or vertical position.
     
  8. BigBrocktoon macrumors newbie

    Joined:
    May 2, 2010
    #8
    Well, what does it look like when you turn off the stretch? We were just watching the cartoon movie "Anastasia" on Netflix, and even it is letterboxed. No need to force fullscreen, it looked great.
     
  9. MacBird thread starter macrumors 6502

    Joined:
    Apr 1, 2010
    #9
    That is exactly the problem, with ATV there is no way to change it, 'stretch' is the only viewing mode, whereas with TV or DVD player I have several modes, and one of them always works without clipping or distorted aspect ratio no matter what the format is.
     
  10. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #10
    With my Aquos, I have 'stretch', 'full screen', 'smart stretch', and 'zoom' when using the new Apple TV. The 'full screen' setting is the 720p equivalent of 'dot for dot' in 1080p.

    A.
     
  11. MacBird thread starter macrumors 6502

    Joined:
    Apr 1, 2010
    #11
    My Aquos does only support up to 1080i, ATV runs at 720p and I don't see the 'dot for dot' option. It seems newer models don't have this problem anymore.
     
  12. BigBrocktoon macrumors newbie

    Joined:
    May 2, 2010
    #12
    Then stick it into the HDMI port where the DVD player is, and the DVD into the port that forces the stretch.
     
  13. MacBird thread starter macrumors 6502

    Joined:
    Apr 1, 2010
    #13
    I just unplugged the HDMI cable from the DVD player and attached the ATV and used the same input port. I had to do it this way since the TV has only one HDMI port.
     

Share This Page