ATV2 Encodes Won't Play on ATV1 (Handbrake)

Discussion in 'Apple TV and Home Theater' started by maclook, Jan 12, 2012.

  1. maclook macrumors 65816

    Joined:
    Nov 2, 2008
    #1
    I'm setting up my old Apple TV 1st gen in my house. I've been encoding all of my movies for the ATV2 using Handbrake's ATV2 preset. My Apple TV 1 sees all the videos in my iTunes but can't play the ATV2 encoded videos.

    Is there a reason for this or a way around it? I don't see why I shouldn't just start using the ATV1 preset if the ATV2 can read ATV1 encodes but I also don't understand why it's not working the other way around. They're technically both capable of playing the same videos right?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    The Apple TV 1 has slightly slower playback abilities. Because of this, it can't play anything over, I think, 24 frames per second. While the Apple TV 2 can playback the full 30.
     
  3. maclook thread starter macrumors 65816

    Joined:
    Nov 2, 2008
    #3
    Ugh, that's it. The ATV2 option changes the framerate to 30fps and that's the only change. That's a real pain in the butt.
     
  4. dynaflash macrumors 68020

    Joined:
    Mar 27, 2003
    #4
    atv 1 can play 30 fps but not at 720p, it can at 540p. The atv2 can play back 720 at 30fps.

    as well the atv2 can play back a slightly higher profile.

    If you have both, encode for the atv 1 (least common denominator). On any 24 fps content it will look just as good as the atv 2 version and play on both.

    ----------

    atv2 preset does *not* change the framerate to 30. both atv1 and atv2 preset use the source framerate. However the atv1 preset nerfs down the resolution to <= 540p since the atv1 cannot playback 720p 30 fps content (see above). Well physically it can but iTunes won't allow it.
     

Share This Page