ATV2 - error 3914 when connecting to wireless N

Discussion in 'Apple TV and Home Theater' started by lucinosferatu, Apr 10, 2011.

  1. lucinosferatu macrumors newbie

    Joined:
    Apr 10, 2011
    #1
    My ATV2 was JB with fw 4.2.1, and upgrading to 4.3.1 was a bloody headache for some reason. Anyway, I successfully upgraded to 4.3.1, without JB. However, when I try to connect to my wireless n network, which it never had a problem connecting to just before updating, I'm getting error -3914, and will not connect. It connects to the wireless G no problem, but I have some rather large videos, and wifi G will not suffice.
    Does anyone have any idea as to what this error means? I've searched tirelessly, and the only thing that comes close is error 3194 for ipods and iphones, in attempts to downgrade firmware, and its an itunes error. So not even close to my problem. Any thoughts would be greatly appreciated. Thanks!
     
  2. VinceScales macrumors newbie

    Joined:
    Apr 26, 2006
    #2
    Hey, I had the same problem you did.

    I have a dual band router so I put the 5GHz on N and was having this issue. I dropped it down to mixed g/n and it worked just fine. I am very careful to only put N devices on this network and it solved the problem - I still have 300mbps link speed.
     

Share This Page