ATV2 'error occurred loading this content'

Discussion in 'Apple TV and Home Theater' started by UncleSimit, Aug 14, 2011.

  1. UncleSimit macrumors newbie

    Mar 7, 2011
    I've been having problems streaming some HD TV shows I remuxed (or whatever you call it) recently to stream my Apple TV2. Anytime I try to stream them from my MBP I get the message ' error occurred loading this content', yet I'm able to stream any other HD content without problem.

    To rule out it being a problem with my library, I've tried playing it through my friends Apple TV 2 and it works fine.

    To check whether it's my Apple TV I brought my ATV to my friends and hooked it up to his TV and it worked fine.

    To rule out whether it's my network I changed my router and guess what....still doesn't work.

    Not sure what to do or try now/next...
  2. UncleSimit thread starter macrumors newbie

    Mar 7, 2011

    Strange one but I've tried and tested it with some new stuff I've put through Subler.

    It's an issue of some sort with AC-3 audio. Once I went into preferences on Subler and selected convert ac3 to aac I was able to play/stream the file without problem.

    Just something to note for anyone else.
  3. blueroom macrumors 603


    Feb 15, 2009
    Toronto, Canada
    The ATV2 needs the first audio track to be AAC, the second can be AC3. You can even pile on a directors commentary on a tertiary track.
  4. ebernet macrumors member

    Apr 5, 2005
    Seattle, WA
    I had the same issue with the latest update. I set the audio out to be Dolby digital rather than auto, and the problem went away. My assumption is they are trying to prevent damage to speakers attached to a device that does not support Dolby. Videos with AAC only tracks continue to play properly. Hope that helps!

Share This Page