ATV2 - HDCP (Cannot play Movies)

Discussion in 'Apple TV and Home Theater' started by Zeneth, Jan 1, 2011.

  1. Zeneth, Jan 1, 2011
    Last edited: Jan 2, 2011

    Zeneth macrumors member

    Joined:
    Dec 18, 2010
    #1
    All,

    I have just rented my 2 first movies from itunes store and planned to watch them on my HDTV with my ATV2.

    One movie is SD and the other is HD - I cannot watch either due to HDCP issues.

    When the movies begin to play, they stop with the error message:

    "This content requires HDCP for playblack."

    "HDCP is not supported by my HDMI connection."

    I understand HDCP is High-Bandwidth Digital Content Protection.

    I have tired all 3 HDMI ports on the TV without any change.

    The "Full HD 3D" HDMI cable is brand new (Phillips SWV3481S/17).

    Software and firmware is all current on both Itunes and ATV.

    I have tried turning ATV2 unit and rebooted PC with Itunes off and on again.

    Our TV is this:
    Panasonic PLasma TH-P54S10A
    Manufactured Date Jan 2010.

    I am assuming all itunes movies are HDCP now.

    My HDTV IS HDCP compliant - as is my HDMI cable.

    Please help me overcome this HDCP barrier so i can effectively utilise the ATV2.

    Zeneth.
     
  2. Wavell, Jan 2, 2011
    Last edited: Jan 2, 2011

    Wavell macrumors regular

    Wavell

    Joined:
    Nov 7, 2007
    Location:
    Essex, UK
    #2
    as you say, it should all work !
    Having said that, just so you can troubleshoot a little.. you may want to try replacing the HDMI cable with something a little more "generic" to see what happens ? :)
    just a hunch.. if it were me, I'd be trying that first. Good luck :)
     
  3. Zeneth thread starter macrumors member

    Joined:
    Dec 18, 2010
    #3
    thanks .

    just tried 2 other hdmi cables - no luck.

    is it possible my tv needs a firware update?

    Zeneth
     
  4. 603doug macrumors newbie

    Joined:
    Jan 25, 2009
    #4
    Had same problem(read it is an issue with the update) rebooted atv2 and all is good
     
  5. Zeneth thread starter macrumors member

    Joined:
    Dec 18, 2010
    #5
    doug - when you say u rebooted your atv2, do you mean restore or reset or other?

    Zeneth
     
  6. 603doug macrumors newbie

    Joined:
    Jan 25, 2009
    #6
    unplugged atv from power source then plug back in, that was a week ago everything works well now. Read on apple site folks were having the same issue and having to restore etc. Seems there could be an issue with the latest software, wished I had not hit the update. I know better, been jbing my phone now for a couple of years and u never update until the bugs are worked out.
     
  7. Zeneth thread starter macrumors member

    Joined:
    Dec 18, 2010
    #7
    thanks doug.

    tried all that and have scoured the itunes forum.

    i will now take my atv2 back for exchange and if same thing happens again, i will seek a refund and try another product (and not apple).

    BTW - my atv does not even show anything on the tv panel now at all - like it's in permananent sleep mode ( for 2 hours now ). LED remains on and have tried to repower 5 times.

    thougths on this one??

    Zeneth
     
  8. Zeneth, Jan 2, 2011
    Last edited: Jan 2, 2011

    Zeneth thread starter macrumors member

    Joined:
    Dec 18, 2010
    #8
    SUCCESS ....... for now ......!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!:)

    i have now got my atv2 unit to power back on - and we can play the rented SD movie which is playing now to a happy family.... :)

    No HDCP error message appeared this time.


    This what we did to fix our issues....

    1) Pressed the HDMI cable more firmly into the HDMI port into TV - this allowed the ATV2 to actually show/reappear onto the tv panel.

    2) Plugged both power leads for TV and ATV DIRECTLY into wall. (Previously, we had both AC leads plugged into a 4x multi power board and had this plugged into the wall.

    We started the SD movie and no HDCP error appeared and movie is still playing as i type...

    Now, to repeat this error/diagnostic, we then plugged the TV power lead back into the 4 x multi power board and plugged the board back into the wall. Immediately, the dreaded HDCP error re-appeared. We then replugged TV back into wall directly and no HDCP error message.

    Hypothesis #1 :
    Now, this 4 x multi power board also had our DVD player and stereo connected to it. Perhaps our DVD (potential recording device) was being detected and hence the HDCP barrier came up so that we were not able to record this movie.... just a hunch but sounds plausible.....

    Hypothesis #2 :
    Also, this 4 x multi power board was within immediate vacinity of the ATV2 unit. Possible interference.....

    Hypothesis #3 :
    Faulty multi powerboard. Will replace and test in same position.


    When the 'dust' settles and the family finishes watching the movies, (1 x HD , 1 x SD), i will plug the 4 x multi power board into another AC wall socket way out of the way of the ATV2 unit (around 4m) and try to repeat this error to validate my hypotheses - noted above.

    I will report findings later in around 6 hours...

    thanks for your help people...
     
  9. Zeneth thread starter macrumors member

    Joined:
    Dec 18, 2010
    #9
    ok -

    both hd and sd movies work.

    i replaced the 4 x multi power board with a new one and retained the same location.

    i am now confident to state that the cause of my HDCP woes is a faulty power board only.

    i hope this helps others...

    Zeneth.
     
  10. shmeffrey macrumors member

    Joined:
    Nov 9, 2009
    Location:
    Toronto Canada
    #10
    Thanks for posting your results, I am having the same issue with HDCP warnings and will try to make some changes later and see if I have any success.
     
  11. 3goldens macrumors 68000

    3goldens

    Joined:
    Feb 26, 2008
    #11
    Apple should fix this very annoying and persistent problem. This happens to me all the time and I have to unplug the gard dam thing and start all over. Get it together Apple and fix the damm problem!
     

Share This Page