ATV2 HDCP Issues

Discussion in 'Apple TV and Home Theater' started by Techgargoyle, Feb 2, 2011.

  1. Techgargoyle macrumors newbie

    Feb 2, 2011
    Every time I try to view any kind of video on my ATV2, whether it be Netflix movies, Itunes rentals, or streams over Airplay, I receive the dreaded HDCP error message. Strangely, when I reset the TV, the message does not appear and everything is fine. But after the TV is turned off for any period of time, the error message becomes a problem again and a reset is needed. It is very annoying to have to reset the TV every day just for the sake of Apple TV.

    I have spoken with Apple phone support, spoken with Genius Bar, have swapped out the ATV2 at my local Apple store, and still the same problem.

    The ATV2 is connected via HDMI to a brand new Mitsubishi 3D-ready DLP HDTV (Model WD6738). And yes, this TV is HDCP compliant.

  2. milbournosphere macrumors 6502a


    Mar 3, 2009
    San Diego, CA
    You know, I've seen lot of these threads started in the past few days. I wonder if it's something to do with a recent update or some such thing. At least resetting your TV is working, a lot of people can't even do that. I've yet to have problems with my aTV2 *crosses fingers*.
  3. FreedomHD macrumors newbie

    Feb 5, 2011
    I had same issue but i didn't have a HDMi display at all.
    I'm using a MITS 65 inch RPTV from 2005 so i just bought HDfury and since that time no more HDCP issue and wonderful picture quality.
  4. ghoti macrumors member

    Sep 12, 2008
    Same here. Netflix won't play anything via my ATV2. XBOX 360 works fine for Netflix, as does the Macbook. All I get on Netflix for the past three days is a spinning wheel, an occasional HDCP message after a long wheel-spin session, and one or two things will play once in a while.

    Really sucks.
  5. DrumGuy macrumors newbie

    Aug 6, 2011
    I just got my first HDCP error message this morning. I've had my ATV2 for over 3 months and it worked with no issues. I noticed this error after I updated to iOS version 4.3 (2557) now my ATV2 is a paper weight and Apple won't even talk to me unless I buy extended coverage for $30. Total BS! :mad:
  6. EmpyreanUK macrumors regular

    Mar 6, 2011
    I started getting this problem out of the blue (it possibly coincided with one of the updates, I can't remember). In the end it turned out that the HDMI cable I was using was faulty (or had become faulty). I was able to confirm this by using the same cable with my PS3, which resulted in the screen randomly turning black for a second or so whilst playing games.

    I don't for a minute suspect that dodgy HDMI cables are behind all of the HDCP issues people are having, but it's still worth investigating.

Share This Page