ATV2 - how to run audio through digital out only?

lifeinabox

macrumors newbie
Original poster
Mar 24, 2012
13
12
Perhaps I'm missing an obvious setting, but how do I make the ATV2 default audio to the digital out (toslink) only and not through HDMI? Thanks.
 

Bymatt

macrumors member
Aug 11, 2011
48
0
On my ATV2 it does out on both. SO on my AVR

I set the chosen input port on the AVR to DIGITAL which gives me the tosslink connection with the digital audio from the ATV2 going into the AVR for processing to the speakers. I run the HDMI out cable of the ATV2 directly up to the Flat screen monitor HDMI input of my choice, I have 4 available.
Since I did this instead of using the HDMI cable for AUD and VID into the AVR, my overall sound and I think picture is better. Being somewhat of an earlier AVR, it has 4 HDMI inputs and 3 tosslink inputs, but dont think it was really up to being used that way. MUCH better since I split the ATV2 outputs and ran them directly as described above.
 
Comment

lifeinabox

macrumors newbie
Original poster
Mar 24, 2012
13
12
I set the chosen input port on the AVR to DIGITAL which gives me the tosslink connection with the digital audio from the ATV2 going into the AVR for processing to the speakers. I run the HDMI out cable of the ATV2 directly up to the Flat screen monitor HDMI input of my choice, I have 4 available.
Since I did this instead of using the HDMI cable for AUD and VID into the AVR, my overall sound and I think picture is better. Being somewhat of an earlier AVR, it has 4 HDMI inputs and 3 tosslink inputs, but dont think it was really up to being used that way. MUCH better since I split the ATV2 outputs and ran them directly as described above.
Thanks but I'm looking for a setting through the ATV2 itself. I'm running the toslink to my DAC, which is connected to my 2-channel setup. Trying to avoid the HDMI audio signal to the TV.
 
Comment

slothrob

macrumors 6502
Jun 12, 2007
443
0
Try going to the aTV Settings>Audio menu, and choosing Dolby Digital>On.

With that setting, my TV is unable to play the Dolby Digital, so the audio goes through the optical to my receiver and the TV is silent.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.