ATV2 + Netflix - :( Please, help!

Discussion in 'Apple TV and Home Theater' started by mikeBCpro5, Nov 30, 2010.

  1. mikeBCpro5 macrumors newbie

    Joined:
    Oct 13, 2009
    Location:
    Oklahoma
    #1
    I just received an Apple TV for my birthday. It is hooked up to my brand new 55" 1080p TV as well. I've streamed iTunes stuff and all has worked without any problems but Netflix will not work. Everytime I try to view a show or movie I get the spinning beach ball for awhile and then a message on the screen says: Sorry we could not reach the netflix service. Please try again later. IF the problem persists please visit the netflix website.

    Should I just take the ATV2 back or is there a fix?

    Thank you in advance!
     
  2. mdatwood macrumors 6502a

    Joined:
    Mar 14, 2010
    Location:
    Denver, CO
    #2
    Are you sure your ATV2 is getting on the internet? Can you play a youtube video?

    If you're sure your internet works, then try NF streaming from your computer to verify that your internal network is getting to NF okay. Once that works then try the ATV again.
     
  3. iggypod macrumors 6502a

    iggypod

    Joined:
    Jun 23, 2010
    #3
    Ive also had that before and it is usually resolved by unplugging and replugging in the ATV unit.
     
  4. RickM21 macrumors newbie

    Joined:
    Jun 29, 2010
    #4
    Yea, I had the same issue earlier, just turned ATV off then back on, it worked fine. I thought it was a problem from netflix actually because I was able to see the titles and info just when you tried to load the movie it kinda got stuck. Dont sweat it.
     

Share This Page