ATV2 not showing as a device in itunes **Solved**

Discussion in 'Apple TV and Home Theater' started by trignflo, Dec 29, 2010.

  1. trignflo, Dec 29, 2010
    Last edited: Dec 29, 2010

    trignflo macrumors newbie

    Joined:
    Dec 29, 2010
    #1
    After extensive searching I am struggling to find a solution for this.

    ATV2 works fine on everything except movie rentals where it won't accept my itunes account credentials. Searching forums suggests that I need to authorise my itunes account on my MAC and with the ATV2 connected it will authorise both and allow me to proceed.

    No matter what I do I cannot get the ATV2 to appear as a device on my 27" Mac. I have ATV via ethernet and MAC, I have disabled all firewall on router (BT Home Hub2) without any change, I have tried connected wirelessly, ATV2 connects fine, plays movie trailers but again won't allow me to put in ITunes store log in details. I know they are correct as I have every time I try and re-authorise the account.

    Are there any pearls of wisdom as to how to the itunes to see the ATV2?

    Itunes and ATV2 software up-to-date, home sharing is on, I can control ATV via ipod touch remote although this has been a bit hit and miss (remote app updated today and seems to be better)

    This is quite frustrating as everyone else seems to be able to rent movies....
     
  2. chenks macrumors 6502a

    chenks

    Joined:
    Oct 23, 2007
    Location:
    UK
    #2
    the new appletv is not supposed to show up as a device in itunes.
     
  3. trignflo thread starter macrumors newbie

    Joined:
    Dec 29, 2010
    #3
    Thank you for response, I have now realised that I can see ATV2 as speakers in itunes and send content to them, however I still cannot get ATV2 to allow me to sign into store even though I know passcode and username correctly input.
     
  4. trignflo thread starter macrumors newbie

    Joined:
    Dec 29, 2010
    #4
    Ok, I'm happy now and have come to the following conclusions. :apple:tv2 will not show up as a device in Itunes 10, you will be able to see it in the bottom right hand corner and can select it if you wish to send media / tunes to the :apple:tv2 system.

    In order to get movie rental working (as it would allow me to sign in) I went to settings / reset / restore, took around 10 minutes but when I initialised it again, accepted itunes password for setting up home sharing and then allowed movie rental after credit card verification.

    The only other thing was that after reading some people had issues with rentals taking 2 - 3 hours before being ready, mine took around 15 seconds before it said ready to view.
     

Share This Page