ATV2 Sometimes Doesn't Recognize Computer

Discussion in 'Apple TV and Home Theater' started by Ticket Eagle, Jan 27, 2011.

  1. Ticket Eagle macrumors newbie

    May 15, 2009
    Every once in awhile, my ATV2 fails to recognize my computer even though the computer is out of sleep mode and itunes is open. Anyone else have this problem? Is it remedied by a simple unplugging and, if not, is there something else I should be doing? I'm thinking of arranging my setup in such a way that unplugging would be a pain, so if that would work, I'd still like to know if it's the only fix. Although it only happens every now and then, it would certainly be helpful to know how to correct the problem whenever it does happen. Thanks in advance for any assistance.
  2. leigh103 macrumors newbie

    Dec 13, 2010
    I had the same symptoms, which I used to fix by stopping and restarting home sharing from the Apple TV, but I've not had it since the last update.
  3. Ticket Eagle thread starter macrumors newbie

    May 15, 2009
    Thanks. I'll give that a shot the next time it happens. My main concern is keeping it simple so I can tell my wife what to do if she has a problem when I'm not around. I've got alot of my kids movies saved in itunes and my wife seems to almost always be the one who has this problem.
  4. ngenerator macrumors 68000


    May 12, 2009
    USG Ishimura
    I get this issue too every so often. Usually it's due to Bonjour not automatically starting on my Windows (ugh ;)) PC, so I usually just go into services and start it up manually. I saved a shortcut to Services on my desktop so it's as quick as can be to start it up again. I'd say maybe once every week and a half this happens.
  5. kkent25 macrumors member

    Apr 1, 2007
    I run into the same problem a few times a week. One minute AppleTV sees my iTunes library the next it minute it is gone.:(:(
  6. MorgensterBE, Jan 28, 2011
    Last edited: Jan 28, 2011

    MorgensterBE macrumors newbie

    Jun 6, 2008
    I get this problem a lot more often. I checked everything Apple's support website prescribed, but that didn't do the trick.
    One minute I have a connection, the next it's gone. Same with my iPhone. At home the network consists of a wireless router + modem with a fixed IP that will give IP's to the iMac, iPhone and ATV2 by DHCP. This is starting to irritate me enormously.
    Anyone know of some alternative tricks to finding out what's keeping my iMac, iPhone and ATV2 hidden from eachother the one minute and visible the next?

    ETA: online stuff like youtube, trailers, etc. works flawlessly BTW. No hickups there.

    ETA2: my GF's iTunes on her Vista laptop has no problems with home sharing from my iMac's library. So this really is an ATV2 issue!
  7. Grasbak macrumors 6502

    Jan 17, 2006
    yep same here, happens quite frequently Have to quit and restart itunes or reset appletv to get it to work.

    Also, quite often the appletv light is on when it should be asleep - then sometimes doesnt display on the tv even though the light is on.....

    i assume its software bugs....
  8. MorgensterBE macrumors newbie

    Jun 6, 2008
    And now it simply refuses to use homesharing altogether. Internet still works and everything else is still the same.
  9. WiiDSmoker macrumors 65816


    Sep 15, 2009
    Hermitage, TN
    Happens here as well. There's quite a bit of issues with this Apple TV 2...still love it though
  10. MorgensterBE macrumors newbie

    Jun 6, 2008
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148a Safari/6533.18.5)

    Nope. Not happy at all. So does anyone have any suggestions? So far I have every wifi device connected to a wireless router that has them assigned an IP address through DHCP. But not a local network.
  11. Balin64 macrumors 6502a


    Jul 23, 2002
    In a Mauve Dream
    No Probs Here

    Always works flalessly. I have an iMac, MBP, iPad, and iPhone all connected to ATV2. My set up: Qwest PK 5000, Ethernet to AirPort Extreme. SSID hidden, WPA 2 password.

    I'm actually surprised it all works. Knock on glass...

Share This Page