ATV2 suddenly loses home sharing

Discussion in 'Apple TV and Home Theater' started by newtoiphonesdk, Nov 12, 2010.

  1. newtoiphonesdk macrumors 6502a

    Jul 30, 2010
    I have no internet where i live so I used mywi over USB from my phone to my MacBook. I then enabled internet sharing to airport so that the MacBook would create a network the atv could recognize. After i enabled home sharing i turned off mywi. For a couple weeks everything worked fine with home sharing. Just a few minutes ago, i was streaming from laptop to atv and it suddenly stopped and atv said it lost connection. I checked settings and it still showed it connected to the network but it would freeze at loading my library when i tried to do it again. I ended up having to just reset it. How can i assure this won't happen again
  2. aelalfy macrumors 6502a

    May 2, 2010
    Berlin, Germany

    This is an interesting situation you have here and pretty clever if you ask me. The mywi to enable your computer acess is not unusual, but the clever idea of once connected to enable homesharing and then disconnecting your internet after, thats pretty cool to me.

    Now I'm only guessing here and don't take this as a forsure answer, but I think this has to do with your shutting down on of the two devices, requiring the device to request a new ip when starting up again? Thats one of the only things I can think of in this situation.

    My solution if the above guess is correct? make your ip's static for both devices?

    When you said you had to reset it? you mean reset by going through your initial precedure (ie. mywi giving internet to computer, computer enabling homesharing?) That would maybe explain my guess.


Share This Page