ATV2 won't load local media.

Discussion in 'Apple TV and Home Theater' started by Caolan96, Dec 29, 2010.

  1. Caolan96 macrumors regular

    Joined:
    Apr 18, 2010
    Location:
    Derry, Northern Ireland, UK
    #1
    Hi,

    So I got the new Apple TV, I like it so far however a few complaints..

    I'm in the UK so to watch tv shows i have to download them to my mac and stream them.

    My setup originally was MBA>External HDD&AirPortExtreme>AppleTV

    but seeing I didn't want to have my MBA turned on all the time, I decided to add all the tv shows I had in my library on my MBA (which were actually on the HDD plugged into the AirPort extreme) to my always on PC downstairs.

    This worked great, until this morning, when it suddenly refused to play any media from the windows computer's library. I've tried everything, resetting the Airport, restarting the PC, restarting Apple TV, but it's just keeps showing the little buffering wheel where the play button normally is.

    It goes into the library, and into the full screen view for the show, but then it just won't play the show. The weird thing is, the grey scrub bar, that shows the media has buffered, is there, and it lets me skim through the with fast forward and rewind, but it just wont play because that spinning wheel is there.

    I know it's not because the media is on an external HDD because it plays fine when I select it from my MBA iTunes instead of the PC. (It does play on the PC in iTunes btw, just not on ATV.)

    Thanks for reading this rather lengthy post.

    Any help would be appreciated.

    Regards,
    Caolán.
     
  2. jcschlic macrumors regular

    Joined:
    Jan 13, 2009
    #2
    Windows...I could go on and on...

    This is what I would do:

    Start over fresh by re-adding the media (delete the media from iTunes, then re-add to the library).

    Try that and see if it works.

    If that doesn't work, there may be a "sharing" issue going on with Windows.
     
  3. newagemac macrumors 68020

    Joined:
    Mar 31, 2010
    #3
    Before you do that, try just rebooting the Apple TV by holding the menu+down button for 5 seconds.
     
  4. Dodgeroo macrumors regular

    Joined:
    Mar 28, 2010
    #4
    I have also found that sometimes Home Sharing isn't working, even though it's showing on the PC iTunes. Try turning it off and on again. /itcrowd
     
  5. Caolan96, Dec 29, 2010
    Last edited: Jul 29, 2011

    Caolan96 thread starter macrumors regular

    Joined:
    Apr 18, 2010
    Location:
    Derry, Northern Ireland, UK
    #5
    oh believe me i could go on about windows as well, i hate the thing.

    anyway, i sorted the problem by moving the media onto the windows hdd rather than keeping it on an external.

    i think it's the crappy wireless card in the pc that was resulting in the buffer, instead of the proccess going like this: pc>airport>external hdd>pc>airport>atv

    it now goes like this: pc>airport>atv.

    although it baffles me because my MBA can do the first one just fine.

    oh well.
     
  6. Caolan96 thread starter macrumors regular

    Joined:
    Apr 18, 2010
    Location:
    Derry, Northern Ireland, UK
    #6
    okay so now idiotically i held down menu and select instead of menu and down, i incremented the apple remote UID - now the remote is not responding, but apple tv says its connected.

    anyone know what to do?
     
  7. newagemac macrumors 68020

    Joined:
    Mar 31, 2010

Share This Page