ATV3 AirPlay Mirroring - Video, no audio

Discussion in 'Apple TV and Home Theater' started by sdilley14, Sep 24, 2012.

  1. sdilley14 macrumors 65816

    Joined:
    Feb 8, 2007
    Location:
    Mesa, AZ
    #1
    I have been having this problem, and it seems to be somewhat common amongst other ATV3 users.

    I get a video going on my MBA, try to mirror it up to my TV...the video mirrors just fine, but the audio continues to come out of the MBA speakers rather than the TV. However, if I turn the volume up or down, the little "audio up and down squeak tone" comes from the TV.

    I have had this happen in the past and I would just restart the ATV3 and that would usually fix it (actually I would just put it to sleep rather than doing the full restart). Sometimes I would have to sleep/wake it a couple times, but it would eventually work. Last night I tried and tried and tried, sleep/wake like 10 times, manually restarted the ATV like 5 times, restarted the MBA, disconnected and reconnected wifi, everything, and I just couldn't get the audio to mirror to the TV. Finally I just gave up and decided to watch the video on the MBA.

    Is there any sort of fix for this other than restarting? FWIW I have a 2012 MBA, ATV3, and a regular old Netgear router.
     
  2. testerdennis macrumors member

    Joined:
    Aug 7, 2011
    #2
    By chance are you using airplay through VLC ?
     
  3. zhenya macrumors 603

    zhenya

    Joined:
    Jan 6, 2005
    #3
    Are you going to System Preferences --> Sound (on the MBA) and setting the ATV as the output source?
     
  4. sdilley14 thread starter macrumors 65816

    Joined:
    Feb 8, 2007
    Location:
    Mesa, AZ
    #4
    Well, funny thing is, I tried opening the file (AVI) with QuickTime and every time I did it would crash. It opened just fine using VLC so that was the program I was using to play the file.

    ----------

    Yes, made sure to have that setting done correctly.
     
  5. Kroner macrumors regular

    Kroner

    Joined:
    Jul 13, 2011
    Location:
    Norway
    #5
    Since you are using VLC, have you tried going to the sound menu in VLC and change the audio device to airplay?
     
  6. sdilley14 thread starter macrumors 65816

    Joined:
    Feb 8, 2007
    Location:
    Mesa, AZ
    #6
    I messed around a little bit in VLC settings but didn't realize this was an option. I will have to give it a try and see if that corrects it. Thanks!
     
  7. martinm0 macrumors 6502a

    Joined:
    Feb 27, 2010
    #7
    I've run into this a number of times as well. Somehow VLC causes some disconnect with the Audio settings in System Prefs. A number of times I have to close VLC and make the updates in Sys Prefs and then I'm usually good to go. But, sometimes it just gets wonky and you have to kill everything and manually change things.
     
  8. testerdennis macrumors member

    Joined:
    Aug 7, 2011
    #8
    That's what I was going to tell you.. @ the top click the audio tab then you will see it
     
  9. Kroner macrumors regular

    Kroner

    Joined:
    Jul 13, 2011
    Location:
    Norway
    #9
    Yep, I thought you were hinting about that when you asked about VLC. Rather annoying sometimes when I want to listen to something on my headphones, and no sound plays, making me slightly confused for a seccond or two :p


    That is what I usually do, quit VLC and open the video again. For some reason I find it less bothersome than going to the settings and change it there :p
     

Share This Page