ATV3 cover art caching

roidy

macrumors 65816
Original poster
Dec 30, 2008
1,025
21
Nottingham, UK
So I bit the bullet and purchased an ATV3, but I'm having problems with the caching of coverart with homesharing. On my ATV1 once the cover art for my own library had been cached I could zip through the menus to my hearts content and the cover art would instantly appear making it a great experience, the only time any cover art would be lost is if the power to the ATV1 went out. However on the ATV3 when I goto say movies in homesharing it takes 3-4 second to cache each piece of coverart, which is fine the first time as after that, like on the ATV1, I can zip through the list and the cover art appears instantly. But once I navigate away from my homesharing to say the store and then go back to movies in homesharing again it re-caches all the artwork again, which is bloody annoying.

It's not a network problem as the ATV3 is hardwired to my iTunes server, anyone have any ideas?
 

whooleytoo

macrumors 604
Aug 2, 2002
6,569
641
Cork, Ireland.
I'm not aware of any way to change this. The ATV2 & 3 have (relatively) limited storage, and the priority of its use is streaming. They could cache all the album and video artwork, but chances are they might have to wipe it occasionally anyway whenever a 1080p is being streamed.

It is a little annoying, even on a fast-ish Powerline connection between my ATV and server, it still takes quite a bit of time for the artwork to load.
 

roidy

macrumors 65816
Original poster
Dec 30, 2008
1,025
21
Nottingham, UK
Yep, would of been nice if they'd of reserved a gig or 2 of the storage just as a permanent artwork cache.
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
Yep, would of been nice if they'd of reserved a gig or 2 of the storage just as a permanent artwork cache.
My old system had a 256MB sd card that was used for artwork/metadata and that worked fine. So even GB's are not needed. The artwork files are actually very small.
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
agreed those album arts only us about 100KB each, not sure why they take so long to cache
Not quite sure why they don't stay cached. If I leave the aTV sitting a long while (maybe a week) without being used, it has to re-cache all of the artwork. I don't turn it off, and it does not sleep. Is it possible that it never cache's the artwork on the aTV and totally relies on iTunes for that? I do put my MBP to sleep overnight or restart occasionally. I wonder if it loses the artwork when that occurs? It's a mystery. :rolleyes:
 

roidy

macrumors 65816
Original poster
Dec 30, 2008
1,025
21
Nottingham, UK
My old system had a 256MB sd card that was used for artwork/metadata and that worked fine. So even GB's are not needed. The artwork files are actually very small.
My artwork ranges in size from 200-300kB so a 1GB reserved cache would allow you to permenantly store 3500-5000 pieces of artwork (assuming no comperssion is done to them on the ATV), more than enough for most librarys. So yep Apple could probably get away with just reserving half a gig and still make the interface experience much better.

Apple really needs to hire people who actually use these devices day in and day out and who know exactly what features need to be included or fixed.
 

extracampine

macrumors newbie
Jun 2, 2012
13
2
I am having exactly the same issue. How can I get my ATV3 to remember the small movie cover images, without having to reload them each time? At the moment I have to wait a few seconds each time when flicking through my movies if I want to see the movie cover. Seems bizarre - am I doing something wrong?
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
I am having exactly the same issue. How can I get my ATV3 to remember the small movie cover images, without having to reload them each time? At the moment I have to wait a few seconds each time when flicking through my movies if I want to see the movie cover. Seems bizarre - am I doing something wrong?
Not sure what your particular situation is but I can tell you how I improved it...I took my daughters old 2006 MB and now use it as a server to feed my aTV. There is still a small delay if I haven't been on the aTV for a while, but it has really speeded things up. Can you go wired?
 

extracampine

macrumors newbie
Jun 2, 2012
13
2
I think it is wired - the ATV3 is connected via ethernet to an Apple Airport Extreme. The Airport Extreme is connected to the NAS via ethernet cable --- home plug --- home plug --- ethernet cable --- NAS.
 

mic j

macrumors 68030
Mar 15, 2012
2,656
150
I think it is wired - the ATV3 is connected via ethernet to an Apple Airport Extreme. The Airport Extreme is connected to the NAS via ethernet cable --- home plug --- home plug --- ethernet cable --- NAS.
Well, if the cover art is not displayed quickly with that setup, it must be an internal aTV caching weakness. So there is probably not much you can do in that case. Have you updated to the latest OS yet? I did it today and thought the cover art appearance was a touch quicker. Wishful thinking? ;)
 

extracampine

macrumors newbie
Jun 2, 2012
13
2
Thanks for your comment. I did update the firmware a few weeks ago but I'll double check that there isn't a newer update. It probably is that ATV itself that is causing the issue.
 

Similar threads

Replies
1
Views
362
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.