Atv3 disconnects from home sharing

Discussion in 'Apple TV and Home Theater' started by kevo1011, Aug 29, 2014.

  1. kevo1011 macrumors regular

    Joined:
    Oct 3, 2010
    #1
    I just updated to win7 and now my atv3's are disconnecting from randomly iTunes home sharing. I searched the web and learned that this is a reported problem, but no fixes. Has anyone found a fix? I can't even watch a complete movie.

    Win7
    Latest itunes
    1 wired Atv3
    1 wireless atv3
    About 25 Mbps speed
     
  2. monty77 macrumors 6502a

    Joined:
    Mar 4, 2005
    Location:
    UK, South Coast
    #2
    Windows 7 out of the box has some issues with being a server of any kind it seems, my Sonos was broken for months (kept losing network shares) until I made the following changes:

    http://forums.sonos.com/showpost.php?p=177853&postcount=18

    ..wonder if it could be related?

    The losing home sharing thing was one of the key reasons I moved all my media to Plex, but that was nothing to do with Windows 7 as my library was on OS X at the time.
     
  3. MFL2012 macrumors member

    Joined:
    Jul 27, 2012
    #3
    Unplug both your ATVs for a minute or so, restart your computer, and try again. If that doesn't work, log out of home sharing and the iTunes store on the ATVs and your computer and then log back in.
     
  4. monty77 macrumors 6502a

    Joined:
    Mar 4, 2005
    Location:
    UK, South Coast
    #4
    ..and that'll bring it back, for a while, then it'll do it again. It's a hugely widespread problem sadly.
     
  5. ghunt1000 macrumors newbie

    Joined:
    Sep 29, 2014
    #5
    I was having this issue with my iPhone and iPad. The "Shared" files would show up for a time after signing out and then signing back in to Home Sharing in iTunes.

    What fixed it for me was to disable IPv6 on my computer that is the iTunes "Server". Go into the properties for the network card in the computer that is running iTunes and uncheck the check box beside
    "Internet Protocol Version 6 (TCP/IPv6)"

    Ever since doing this, I have been able to access Home Sharing consistently.
     

Share This Page