ATV3 doesn't stay connected to Macbook Pro

Discussion in 'Apple TV and Home Theater' started by chronomac, Nov 20, 2012.

  1. chronomac macrumors newbie

    Oct 10, 2009
    I bought my ATV (3rd generation) about 2 months ago. Up until last week, it's been working perfectly. Netflix, iTunes, DVD rips, Blu-ray rips. They all worked fine.

    But now when I turn on my ATV3 and iTunes on my Macbook, my ATV3 doesn't show any iTunes connection with Home Sharing. It just has that Home Sharing icon and wants me to turn on iTunes, which is already on. So I either do one of three things: 1. Turn off wi-fi on my Macbook and then back on. 2. Restart iTunes. 3. Restart the ATV3.

    Usually one of those things fixes it and the ATV3 can see my iTunes content and we're fine. But after watching an episode of a TV show or a movie it fails again. It still shows my listings but when I select one it loads forever, fails, and when I go back to the main menu the problem starts again and I try my 3-prong solution.

    I did a little research and while I didn't find an answer (hence why I'm posting this), some people thought it was because of a recent update, either for the ATV3 or Mac OS X.
  2. here2rock macrumors regular

    Mar 23, 2012
    Normally restarting the ATV will fix the problem. Have you updated the firmware and iTunes to the latest version?
  3. waw74 macrumors 68030

    May 27, 2008
    try rebooting your wireless router, this has fixed similar problems for me before.
  4. chronomac thread starter macrumors newbie

    Oct 10, 2009
    The ATV3 and iTunes on the Macbook Pro are both up to date, as is Mac OS X. Restarting the router only helps temporarily. I turned it on just now to check and it didn't connect at first but did after I went though the ATV's settings to restart. Hopefully that'll solve it. If not, though, what else can I try?
  5. mic j macrumors 68030

    Mar 15, 2012
    Are you operating wired or wireless for aTV to router?
  6. chronomac thread starter macrumors newbie

    Oct 10, 2009
    The ATV3 has a wired connection to the router. The Macbook Pro has a wireless one.
  7. ser968 macrumors member

    May 18, 2008
    Same thing is happening to me. The only remedy I found was to change the ATV's settings to not put it to sleep. Once I did that, the iTunes connection never dropped.
  8. mic j macrumors 68030

    Mar 15, 2012
    Try operating the aTV wirelessly and see if that helps. There have been some threads indicating that operating the aTV wired can be the source of the problem.
  9. chronomac thread starter macrumors newbie

    Oct 10, 2009
    Would it help if I downgraded my ATV 3 to an older version? If so, how do I do that and what version should I use?
  10. Neotribe macrumors newbie

    Dec 12, 2011
    Same problem

    I have been using my ATV 3 for almost a year with no problems. Then, it recently started to not find my iMac. Usually, if I restarted my Mac and ATV it would find it. But since updating to itunes 11, I have only been able to get it to find my computer once.
    When it did, I couldn't get it to play any of the songs or movies. It would just give me the loading icon for a few minutes until I gave up. I haven't moved the computer or the Apple TV. So I have no idea why it isn't working. It seems to find Youtube etc. no problem. It just can't find my computer.

    This is the first negative experience I have had with Apple products and my house is filled with them!
  11. shadow puppet macrumors 6502

    shadow puppet

    Dec 2, 2012
    4th padded cell on the right
    My downgrade to 5.0.2 solved my connection issues

    I was going bald from tearing my hair out after upgrading my Apply TV3 to 5.1.1. Connection kept dropping about every 3 minutes. Restarts helped maybe one time in 7 tries but alway lost the connection after just a few minutes. I had similar problems with the last upgrade, although not was often or severe. My Apple TV3 is only a few months old.

    Then I came across this suggestion & downgraded to 5.0.2 & it worked:

    One thing for me since I'm still on SL, I held down OPTION, not SHIFT as the poster lists. Other than that, if you do this, follow his connection instructions to the letter or you won't see the option to restore and search for what version you want to use. Now everything plays nicely together again and so far, no connection time outs with iTunes. I have read that iTunes 11 is also causing problems but I didn't jump on that upgrade yet so can't speak from personal experience.

    I don't know how long the window to downgrade will be available so if you're at all interested in giving this a try, I'd suggest doing it sooner than later.

    Hope this helps.
  12. chronomac thread starter macrumors newbie

    Oct 10, 2009
    Thanks for this link. I'm going to get a mini-USB cable from a friend tomorrow and try it out. The way my ATV is acting now, it's a lot less useful than it used to be. Netflix still works great but the biggest selling point of the device is riddled with issues and a pain in the ass to use. Apple should get on this issue.

Share This Page