ATV3 Family sharing bug/messed up?!

Discussion in 'Apple TV and Home Theater' started by Salmonchaser, Nov 16, 2015.

  1. Salmonchaser macrumors newbie

    Joined:
    Dec 7, 2012
    #1
    I have an iMac that runs iTunes for the household.
    Family sharing is set up with me as the organizer and my wife as a family member. All permissions are enabled for home sharing and family sharing.

    All content that I purchase on my iTunes account and either stream or download to my iTunes library plays fine and is accessible via my ATV3.

    However, content (movies) that my wife purchases under family sharing (she purchases with her iTunes account, but my cc pays for it) doesn't work properly. I can download her purchases into my iTunes library, and play them on my iMac screen fine, but the ATV3 throws an Authorization Required error (saying my computer is not authorized to play the content) when I try to play them via "Computer" on the ATV3 (i.e. ATV3 accessing the files from my iTunes library). They will stream online from Apple fine on the ATV3 if I access the files that way.

    Also, if I try to Airplay the files from my iMac to the ATV3, I get an HDCP error?!? I only ever get that message via Airplay with family sharing content purchased by my wife.

    Seems to me that something in Family Sharing is totally borked!

    iMac =late 2013, running latest El Capitan update and iTunes
    AT3=latest software update
     
  2. eRondeau macrumors 6502a

    eRondeau

    Joined:
    Mar 3, 2004
    Location:
    Canada's South Coast
    #2
    Reboot everything including your Airport (router).
     
  3. Salmonchaser thread starter macrumors newbie

    Joined:
    Dec 7, 2012
    #3
    Will try rebooting my Airport extreme. Only component that I haven't tried a full reboot on yet, but sceptical that the Airport would have an effect.
     
  4. -Gonzo- macrumors regular

    Joined:
    Nov 14, 2015
    #4
    May I ask why are you accessing her purchased films that way?
    Have you tried just going to Purchased under Movies on the ATV and selecting Shared Films?
     
  5. Salmonchaser thread starter macrumors newbie

    Joined:
    Dec 7, 2012
    #5
    Yes, that is how we ended up watching the film.

    However, that's not the point. Family sharing enables you to have a central iTunes server that serves the household via a central library. I shouldn't have to keep re-streaming a purchase from Apple. Sucks for bandwidth, and if network is slow or down, streaming is a bad option.

    In any case, after every option tried, the solution turned out to finally be unplugging the ATV3, leaving for a minute then plugging back in. Not even a restart through the UI would do it.
     

Share This Page