ATV3 not playing/streaming some files with Home Sharing...

Discussion in 'Apple TV and Home Theater' started by gpspad, Jan 11, 2017.

  1. gpspad
    Expand Collapse
    macrumors 6502

    Joined:
    Feb 4, 2014
    #1
    I have a mac mini setup to home share iTunes and a ATV3 connected to a HDTV on my network.

    I ripped some workout videos with handbrake, then used subler to add my own soundtrack and some chapter markers.

    The videos play fine with iTunes on the mac mini, I can select them on the ATV3, but when I try load them on the ATV3 or even stream them from the mac mini using airplay the ATV3 just will not play them, It just spins the pin wheel and does nothing.

    The mac mini is uploading data to the ATV3 I can see it with activity monitor, it just won't play anything. the thing is I did about 6 workout dvd's most of the m4v's play, a few just don't seem to load. I did them all the same way with handbrake and subler. Cant figure out why it wont play some....
     
  2. vertical smile
    Expand Collapse
    macrumors 68020

    vertical smile

    Joined:
    Sep 23, 2014
    #2
    Have you tried to re-encode the videos that do not play from the disk?

    I am not an expert at all, but sometimes when I have issues with videos, I re-encode those video from the already encoded files, in your case the videos in iTunes that wont stream.

    Re-encode them using HandBrake and keep just the simple ATV3 presets.

    Again, this is not using the disk, but encoding the m4v's that are already in iTunes.

    Might be worth a try.
     
  3. gpspad
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Feb 4, 2014
    #3
    Actually it got weirder, I left the pin wheel just going then suddenly it just started playing the video.

    The ATV3 has limited memory, so i find it hard to believe it is storing all that data its uploading. Its frustrating.
     
  4. priitv8, Jan 11, 2017
    Last edited: Jan 14, 2017

    priitv8
    Expand Collapse
    macrumors 68030

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #4
    Your video file definitely has a problem.
    I have yet to see an aTV-compatible file from HandBrake that won't play or start to play after brief initial buffering.
    So you must have broken it with Subler while adding tracks.
    To begin with, try a simple thing - take the Optimize command (Shift+Cmd+O) from Subler File menu.
    This will rearrange the MP4 structures so that headers are at the beginning of file and received ahead of media content - so playback can start without seeking until end of file.
    Screen Shot 2017-01-12 at 08.16.45.PNG
     
  5. gpspad
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Feb 4, 2014
    #5
    Thanks so much, that did it. Does the optimize command degrade quality at all?

    I am guessing I should do it all the time I add chapters and tracks?
     
  6. priitv8
    Expand Collapse
    macrumors 68030

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #6
    No, it won't do any change to content of the tracks (ie media or metadata).
    It will just bring the vital data containig info about file content to the beginnig, so it is received early on.
    I have seen such problems when adding audio tracks. Not so with chapter tracks.
    http://www.iphonelife.com/blog/87/t...ng-your-video-files-apple-tv-3-streaming-tips
     
  7. niteflyr
    Expand Collapse
    macrumors 6502a

    Joined:
    Nov 29, 2011
    Location:
    Southern Cal
    #7
    Checking the "Web Optimized" box in Handbrake will do the the same thing.
     
  8. vertical smile
    Expand Collapse
    macrumors 68020

    vertical smile

    Joined:
    Sep 23, 2014
    #8
    I been doing that for years with handbrake, not knowing exactly what it did. I figured it had something to do with streaming.
     
  9. priitv8
    Expand Collapse
    macrumors 68030

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #9
    Good point. I have had this option checked since my early days of HB usage and hence have forgotten about it.
     

Share This Page