ATV3 suddenly won't work on ethernet

Discussion in 'Apple TV and Home Theater' started by squidkitten, Jan 14, 2013.

  1. squidkitten macrumors 6502


    Mar 10, 2012
    So we rearranged our living room and ended up having to get new ethernet cables to wire around for our Apple TV and Roku boxes. I live on a University campus where I HAVE to use ethernet to access the internet on devices that cannot log in via webpage. I've never had any problem with my Apple TV, but suddenly no matter which ethernet cord I use, or which port I use, it no longer works. These same cords and ports work perfectly fine with the Roku our computers.

    I've tried resetting, restoring, everything. I tethered it to my iPhone's mobile hotspot to activate and log in to everything, and it worked just fine. For some reason it's just the ethernet. I'm really confused. Even the cables that worked fine yesterday won't work.

    Any ideas? I live over an hour away from the only Apple Store in this state, so I'd really love to exhaust any alternatives before giving in and driving there. Also, I'm worried they're just going to call it a network issue, which makes no sense if it worked fine on the automatic setting only 24 hours ago!

Share This Page