ATV3, Yosemite and home sharing.

Discussion in 'Apple TV and Home Theater' started by SinbadtheSailor, Aug 3, 2014.

  1. SinbadtheSailor macrumors newbie

    Joined:
    Jul 25, 2013
    #1
    I recently installed the public beta of Yosemite on a 27" iMac and upgraded to iTunes 12. (Upgrade in the loosest sense of the word).

    I use home sharing to access my itunes library through an Ethernet network on an ATV3. Since the installation I am finding frequently that I am unable to access the library on the iMac from the ATV. I need to switch home sharing off and back on again and restart my mac to make it work again. With mavericks this was not a problem and my mac would wake from sleep and work fine when required by the ATV.

    Is anyone else finding these issues, I could downgrade back to mavericks as I have appropriate backups from before I installed Yosemite, but I am loathed to do this if someone knows of a solution?

    I will of course send feed back to apple to help them fix the problem if it is indeed one affecting others.
     
  2. GreatDrok macrumors 6502a

    GreatDrok

    Joined:
    May 1, 2006
    Location:
    New Zealand
    #2
    I updated my Mac mini to Yosemite and iTunes 12 and so far it has worked very well for me. My two Apple TVs (2 and 3) both haven't had any problems. I did recently get sick to death of my Asus wifi boxes and dumped them in favour of Apple's airport express and my connectivity issues have gone away but I was having those before the upgrade to Yosemite.

    I did notice yesterday that my ATV2 had lost connection and restarting it didn't help, but restarting iTunes 12 on the Mac did fix the problem.

    Since I have a private network with an external firewall, I don't run the firewall on OS X but I do on the Windows 7 box where I used to keep my iTunes library. Might be worth checking your Mac firewall settings just to be sure it is either off as mine is, or if it is on that iTunes is in the list of allowed tools although it is signed so should be automatically able to connect anyway.
     
  3. havmir53 macrumors member

    Joined:
    Sep 10, 2014
    #3
    Darn .. II have SAME issue ... and Mavericks was working so darn well ... I can't go back though ... have you come up with a solution ... I can't Home Share anymore ...
     
  4. MedinaJ78 macrumors newbie

    Joined:
    Jan 27, 2009
    Location:
    Japan
  5. ptero1 macrumors newbie

    Joined:
    Nov 13, 2008
    #5
  6. photoj2754 macrumors 6502

    photoj2754

    Joined:
    Oct 10, 2013
    Location:
    Akron
    #6
    Thanks for this. Read the post and sure enough had the same problem after downloading Yosemite. Works perfectly just be sure to restart everything (iTunes, ATV, home sharing) to get it all working again.
     
  7. Cell-666 macrumors 6502

    Joined:
    May 3, 2011
    #7
    New update today has fixed this issue, along with some other AirPlay problems.
     
  8. nick2421 macrumors newbie

    Joined:
    Oct 13, 2011
    #8
    still need to rename the MAC or library to kick homesharing into gear. Not exactly a acceptable fix as mavericks was stable with homesharing.
     
  9. Graz9 macrumors member

    Joined:
    Oct 21, 2014
    #9
    Bonjour

    I have a Mac mini serving 2 ATV3 devices via an airport time capsule and while I do not have an issue seeing my library the issue I have is if any Apple device wakes the Mac for home sharing it can see the library fine, but at this point no other device can see it. If I then disconnect with the original device, it too cannot reconnect. Only when the Mac returns to sleep after the allotted 10 mins, or is put to sleep manually can any device reconnect to the library.

    Anyone else experience this, or is able to reproduce? Currently I am just leaving my Mac throughout the day to ensure connectivity.
     
  10. Lord Hamsa macrumors 6502a

    Joined:
    Jul 16, 2013
    #10
    I tried the whole "change the computer name" approach and that didn't work. What did seem to work was probably what I should have tried first - turn off Home Sharing and then turn it back on again. Presto! Off and running again.
     
  11. 0wls macrumors newbie

    Joined:
    May 24, 2014
    #11
    I'm having the same problem, and none of the fixes are working.

    2012 Mac Mini, ATV3, ethernet connection. Homesharing worked flawlessly until I updated to Yosemite and iTunes 12.

    I've tried turning home sharing off and on (both on the ATV and my Mini), renaming the computer under System Preferences > Sharing, resetting ATV, unplugging everything and plugging it all back in and turning it all off and on again. Nothing works.

    Has anyone found any other possible fixes? This is really pissing me off, as this is my main use of ATV.
     
  12. Dorkington macrumors 6502a

    Joined:
    Apr 5, 2010
  13. bumpynight macrumors newbie

    Joined:
    Nov 10, 2014
    #13
    This is a very frustrating and time-consuming quirk.
    The fix is to turn on Home Sharing using the File menu instead of the Sharing tab in Preferences.
    You might have to turn Home Sharing off and turn back on again.
     

Share This Page