ATV4: Apple Music glitchy and keeps hanging

Discussion in 'Apple TV and Home Theater' started by BAN1, Nov 9, 2015.

  1. BAN1 macrumors newbie

    Joined:
    Nov 9, 2015
    #1
    I recently moved from the Roku 3 to the ATV4, and the primary reason for doing so was to have access to Apple Music through my home theater setup (I had previously used Spotify with Roku).

    Anyway, I am experiencing connectivity drops and songs hanging up mid song or when a new song starts or pretty much anytime. This can happen when I try to skip forward to another song or just start a new album or whatever. It doesn't do it all the time, but it does it enough to be really annoying. Sometimes it resolves itself after a couple of minutes, but other times I have to close out of the program and reload it to get anything playing.

    I've got stable internet connectivity on the ATV as well as all other connected devices (iphone, macbook, ipad) and speedtest results on all show between 40-50 Mbps. I have moved the ATV4 from 5ghz to 2.4ghz and even tried running an ethernet cable to it, but the results have been the same. I've also rebooted a number of times.

    Any thoughts? I can handle the slower Hulu/Netflix/HBO loading times vs the Roku, but I'm not sure if I can handle the glitchy Apple Music playback.

    Thanks!
     
  2. BAN1 thread starter macrumors newbie

    Joined:
    Nov 9, 2015
    #2
    Well, I don't know if it's the 9.0.1 update or if things just finally worked themselves out, but after a week of glitchiness, things have been working really well since yesterday afternoon. Fingers crossed.
     

Share This Page