ATV4 home button inconsistent?

Discussion in 'Apple TV and Home Theater' started by MarvinHC, Mar 10, 2017.

  1. MarvinHC macrumors 6502a

    Joined:
    Jan 9, 2014
    Location:
    Shanghai, PRC
    #1
    Hi,

    does anybody else encounter the following issue:

    When using my Apple TV (4) to watch youtube, when I press the menu (home) button to close a video, sometimes it brings me back to the youtube menu (which it should), sometimes straight back to the home menu of the ATV (i.e. where you select the apps) which is annoying. Any fix / setting that can help there?

    Thank you :)
     
  2. kissfan macrumors regular

    kissfan

    Joined:
    Dec 7, 2011
    Location:
    Florida
    #2
    By design, if you hold it long enough it will go to the home screen.

    Is it possible you're holding it down a bit longer at those times?
     
  3. MarvinHC thread starter macrumors 6502a

    Joined:
    Jan 9, 2014
    Location:
    Shanghai, PRC
    #3
    Thanks for the feedback. I noticed that when I hold it down a bit longer it goes straight there, but even if I push it very briefly, it sometimes jumps there which is rather annoying.

    I still have warranty but have to bring it to another country (as ATV is not sold here in China) and it's one of these things that is rather hard to proof at a genius bar... I checked for settings but couldn't find anywhere to disable this or adjust the sensitive / button speed unfortunately.
     
  4. roidy macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #4
    Mine does exactly the same thing and I don't think its an issue with pressing the menu button too long. If it was then it would also happen in other apps which for me it does not, and it would also happen when going backwards through the menu screens but it only happens during video playback.

    I should also say I'm running the 10.2 beta 5 firmware and I first noticed this issue during 10.2 beta 1, so I'm thinking it's just a software bug. By any chance are you running 10.2 beta?
     
  5. bigcahuna12c macrumors member

    bigcahuna12c

    Joined:
    Aug 30, 2013
    #5
    By your question (menu (home button) it is unclear which button you are pressing.
    Are you pressing the "menu button" or the "home button"?
    By design the "home button" is designed to take you all the way back to home screen.
    The "menu button" is designed to take you back to previous screen with a quick press & all
    the way back to home screen with a long press.
    I have four of the ATV4 & I just launched youtube on all 4 & watched 5 videos on each.
    On each one with a short press of "menu button" I returned to youtube start page.
    While watching video with a long press of "Menu button" I returned to Apple TV home page.
    I have 2 suggestions which may or may not be relevant or fit your situation.
    1st make sure remote is fully charged.
    2nd even though ATV4 does not require line of site maybe it is in an enclosed entertainment center &
    to far away for a clean signal.
    Hope this helps.
     
  6. MarvinHC thread starter macrumors 6502a

    Joined:
    Jan 9, 2014
    Location:
    Shanghai, PRC
    #6
    Thanks, good to hear that I am not the only one, and yes this applies to all video playback (also when playing videos from my iTunes server.
    --- Post Merged, Mar 10, 2017 ---
    You are right I was a bit unclear. I was referring to the button labelled 'Menu'. Line of sight is not always given (one thing that I love about ATV4 - not needing it normally). Will observer further, but so far it seems to be rather random reaction ont the same length of click.
     
  7. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #7
    Yes I have the same issue.

    It has something to do with my thumb touching the touch screen portion of the remote while I'm pressing the button. Every single time it happens I can tell my thumb isn't perfectly centered. But even its inconsistent because I can't intentionally replicate the issue. However it never does it if I make sure my thumb isn't centered.

    Its a bug because I never had this issue before.

    Try it for yourself the next time you see it happen pay attention to your thumb position.
     
  8. JeffPerrin macrumors regular

    JeffPerrin

    Joined:
    Jul 21, 2014
    #8
    The default (single-click) behavior of the Menu button is to act as a "back" button (as per tvOS). However, the app developer can program behavior for the Menu button as well. For example, in the Netflix app, the Menu button will scroll you back to the top of the Netflix menu screen. I always thought the YouTube tvOS app Menu button "issue" was just a product of poor design. (I wish they'd take a Netflix approach to their Menu button behavior)

    //
     
  9. MarvinHC thread starter macrumors 6502a

    Joined:
    Jan 9, 2014
    Location:
    Shanghai, PRC
    #9
    Will check on that, thanks for the feedback. Still a bit annoying. I am going back and forth between ATV4 and ATV3 remote. The touchpad is nice but for the rest I actually prefer the old one.
     
  10. JeffPerrin macrumors regular

    JeffPerrin

    Joined:
    Jul 21, 2014
    #10
    I hear you. I really like the solid, ergonomic feel of the old remote too, but I'm sold on the Siri Remote's bluetooth connectivity.
     
  11. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #11
    I also notice it will back out if I keep pressing 10 second faster forward on the touch section on occasion. Its incredibly annoying, I think its related to the youtube app mostly.
     
  12. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #12
    I didnt read through all of the comments but I had issues with mine at one point so I started with un-pairing then repair remote and hard reboot as in disconnected the aTV from power for a couple minutes and reconnecting.
    I've also set mine to go immediately to home screen and not to the TV app anymore.

    Hope you get it sorted out.
     

Share This Page