ATV4 only puts out 2 Channels - No surround sound

Discussion in 'Apple TV and Home Theater' started by Aragornii, Dec 7, 2015.

  1. Aragornii macrumors 6502

    Joined:
    Jun 25, 2010
    #1
    I swapped out my ATV3 for an ATV4. The ATV 3 had no problem producing surround sound and my satellite box plugged into the same receiver puts out surround sound, but I only get 2 channels coming from the new ATV 4. I've tried adjusting all the output settings and doing a restart to no avail.

    Does anyone else have this issue?
     
  2. Mac... nificent macrumors 6502

    Joined:
    Nov 20, 2012
    #2
    Search engine has plenty of similar replies.
     
  3. rolsskk macrumors 6502

    Joined:
    Sep 1, 2008
    #3
    Have you tried messing around with your receiver at all?

    I had the same issue, but when I did my troubleshooting, I realized that my receiver wasn't recognizing it properly. Once I played around with the receiver's surround settings, it now does it in 5.1.
     
  4. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #4
    i just thought of this, not sure if it will change anything or not

    pull down when watching something , there is a setting about quiet noises.
    it's possible if that's turned on, it's killing the surround.

    not sure how you're determining if you have surround or not, by ear, or by a read-out on your receiver, the following will help
    Example Short 23.976 - this is a file on netflix that will show you your current resolution, it also has channel by channel sweeps and such to trouble shoot your audio, it defiantly has DD5.1, and makes it very easy to hear each speaker.
     
  5. Aragornii, Dec 7, 2015
    Last edited: Dec 7, 2015

    Aragornii thread starter macrumors 6502

    Joined:
    Jun 25, 2010
    #5
    Checked that and it's set to Full Dynamic Range.

    My receiver has a display on the front that shows what channels are coming in. It's definitely 2 channel.

    Edit: did a factory reset. didn't help.
     
  6. loekf macrumors 6502

    loekf

    Joined:
    Mar 23, 2015
    Location:
    Nijmegen, The Netherlands
    #6
    Did you play with the audio output settings ? You can select between auto, dolby surround, stereo. If you have a receiver capable of DTS/DD decode, set it to Dolby Surround if you want the receiver to decode the audio iso ATV4. Otherwise the ATV4 will decode to PCM.

    Also make sure the dynamic range limiter in the ATV4 is disabled. Otherwise passthru will not work and you will get PCM.
     
  7. Aragornii thread starter macrumors 6502

    Joined:
    Jun 25, 2010
    #7

    Thanks for the info. Tried setting it to dolby rather than auto, made sure the dynamic range limiter was off. No luck. Also added the update today. Also no difference.
     
  8. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #8
    For me, whatever the limiter setting, my receiver always reports DD 3/2.1 stream. I have yet to see PCM 5.1 coming in.
     
  9. Aragornii thread starter macrumors 6502

    Joined:
    Jun 25, 2010
    #9
    All - thanks for responding. What ended up working for me was to switch the audio output in the Apple TV settings from "Auto" to "Dolby Surround". What made it complicated was that if I just switched from auto to dolby it didn't work. I had to switch from auto to stereo and then to dolby, and finally I got surround sound. I hope that helps anyone with a similar issue.
     
  10. x-evil-x macrumors 68030

    x-evil-x

    Joined:
    Jul 13, 2008
    #10
    Should it display DD in the audio drop down menu on top? Mine only says full dynamic range and under that is reduce loud sounds. on my receiver it shows DD if the movie or show has it.
     
  11. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #11
    No, it never shows it. From 9.1 update you now even don't see (left to the dynamic range column), if you have both AAC and DD or just one of them in same language.
     
  12. Marshall73 macrumors 6502a

    Marshall73

    Joined:
    Apr 20, 2015
    #12
    I had the same issue, used iTunes to put it back to 9.0.1 which fixed the audio. Disabled auto updates until the next firmware update from Apple so it doesn't go back to 9.1
     
  13. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #13
    I hardly consider this an issue.
    9.1 fixed the most annoying problem of playing stereo music back as DD5.1 stream, so I will not go back to previous versions of tvOS.
     
  14. Marshall73 macrumors 6502a

    Marshall73

    Joined:
    Apr 20, 2015
    #14
    So, no surround sound is not an issue? What a fanny!
     
  15. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #15
    Well, I got only surround all the way with previous versions. Now I get stereo as well.
    For me DD5.1 worked since day 1 on latest aTV.
    Plus - prior to 9.1 I had to manually select the surround track in a movie, now I get it automatically.
    Prior to 9.1, even if stereo track was playing back, it was sent to AVR as a DD5.1 stream, with only L and R carrying sound. Not anymore.
     

Share This Page