ATV4K connects to router but no IP address

iregret

macrumors 6502a
Original poster
Jan 23, 2012
522
117
I've tried two different routers. Both had the same result. I put in the password, appletv connects then doesn't do anything. On the router side, they both reported assigning IP addresses to the appletv, but for whatever reason appletv doesn't see it.

I bought this yesterday and the only way the thing will work is to plug in an ethernet cable. That's not really feasible for me. Do I have a defective appletv?

IMG_7925.jpg
 
  • Like
Reactions: Gonzbull

Gonzbull

macrumors member
Nov 8, 2015
42
13
Mine does the same. Sees the network but won’t connect. I’m getting a longer hdmi cable so I can move it farther away from my router hoping for a fix. It’s currently about 2feet away.
When I connect the ATV to our upstairs bedroom tv it connects to wi-fi just fine.
 

keysofanxiety

macrumors G3
Nov 23, 2011
9,537
25,262
It sounds like an issue with the Apple TV to be honest. To err on the side of caution, you can try to change the wireless encryption on your router to WPA2-PSK (AES) only - no mixed or legacy mode. It may already be on this setting but you can try to change it anyway.
 
  • Like
Reactions: iregret

d_visser

macrumors newbie
Jan 14, 2019
2
0
Tennessee
Mine does the same. Sees the network but won’t connect. I’m getting a longer hdmi cable so I can move it farther away from my router hoping for a fix. It’s currently about 2feet away.
When I connect the ATV to our upstairs bedroom tv it connects to wi-fi just fine.
I had an issue once where a Roku stick was very close to the (802.11ac) wireless router, and it caused a 802.11n laptop to be unable to connect. Temporary solution was: get an 802.11ac dongle for the laptop in question. Better solution was: move the router further away from the Roku.
 

iregret

macrumors 6502a
Original poster
Jan 23, 2012
522
117
I had an issue once where a Roku stick was very close to the (802.11ac) wireless router, and it caused a 802.11n laptop to be unable to connect. Temporary solution was: get an 802.11ac dongle for the laptop in question. Better solution was: move the router further away from the Roku.
I know you werent addressing me specifically, but in my case there is a HomePod 10 feet away from where my Apple TV is that’s working just fine. Hell, when the Apple TV is plugged in to an ethernet cable, the HomePod acts as my Apple TV speaker.

Maybe I should just return this thing to Costco?
 

d_visser

macrumors newbie
Jan 14, 2019
2
0
Tennessee
I know you werent addressing me specifically, but in my case there is a HomePod 10 feet away from where my Apple TV is that’s working just fine. Hell, when the Apple TV is plugged in to an ethernet cable, the HomePod acts as my Apple TV speaker.

Maybe I should just return this thing to Costco?
My general point was, check no WiFi client is within about 3 feet of the router. It can cause connectivity issues for random other WiFi client devices.
 

Gonzbull

macrumors member
Nov 8, 2015
42
13
Well I moved the ATV off the metal cabinet it was on and placed in on a speaker and wi-fi works. Did the whole back and fourth thing and can confirm the metal cabinet is the cause!
Router is on the other side of the speaker so less than a foot away.
 
  • Like
Reactions: iregret

imaccooper

macrumors 6502
May 29, 2014
305
97
North Carolina
This could not be the case, but are you using this at work or on some sort of shared wifi? It just seems unusual (though I have definitely seen some interesting names) that your home wifi network would be called "internet access."

If it is a corporate network or like a full building wifi in an apartment or something, you may be getting blocked by some security policy set up. If you are at home or can access the larger network, I would try to manually assign an ip address in the apple tv settings and see if that works.
 

iregret

macrumors 6502a
Original poster
Jan 23, 2012
522
117
This could not be the case, but are you using this at work or on some sort of shared wifi? It just seems unusual (though I have definitely seen some interesting names) that your home wifi network would be called "internet access."

If it is a corporate network or like a full building wifi in an apartment or something, you may be getting blocked by some security policy set up. If you are at home or can access the larger network, I would try to manually assign an ip address in the apple tv settings and see if that works.
Nope, it's at home connected to an ORBI router setup with 2 satellites. It's a mesh network consisting of 3 separate router/extenders. The range is awesome, but ORBI has been challenging in unusual ways.

I figured it out though and it's the strangest thing.

I turned on MU-MIMO and BEAMFORMING and everything immediately started working as intended. As far as the SSID, it used to be called "Wi-Fight the inevitable?" but I changed it to generic "Internet Access" because I was messing around with the router and I thought it was abstractly funny.
 

imaccooper

macrumors 6502
May 29, 2014
305
97
North Carolina
Nope, it's at home connected to an ORBI router setup with 2 satellites. It's a mesh network consisting of 3 separate router/extenders. The range is awesome, but ORBI has been challenging in unusual ways.

I figured it out though and it's the strangest thing.

I turned on MU-MIMO and BEAMFORMING and everything immediately started working as intended. As far as the SSID, it used to be called "Wi-Fight the inevitable?" but I changed it to generic "Internet Access" because I was messing around with the router and I thought it was abstractly funny.
Strange I guess, but I’ve definitely had more unusual solutions to work for who knows what reason. Glad you got it working.

P.S. I do find your network name abstractly funny, and the original name is quite good also. :)
 
  • Like
Reactions: iregret
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.