ATV4K Unable to Function in 4k

Discussion in 'Apple TV and Home Theater' started by Berman1125, Feb 20, 2018.

  1. Berman1125 macrumors newbie

    Joined:
    Sep 30, 2012
    #1
    I have been having some frustrating issues with my ATV4k and have been unable to come up with an answer to my problem. My ATV bricks up when I use it in 4k hdr and 4k sdr mode. When I go to open up apps, I get the spinning loading wheel and nothing happens. All other apple devices (Iphone, Macbook pro, ATV3) are connected and working fine with the internet. The ATV4k says that it is connected and has a great wifi signal. I am still getting up to 45mbs speeds but ATV4 does nothing. As soon as I switch the ATV4k into 1080p hdr mode, everything functions 100% normal which leads me to believe it's not the hdr but the 4k somehow.

    I don't really know where the issue lies. Router? ATV4k? It is connected via wifi, not a hard connection to the router, I would really like to avoid a long ethernet cable running through my house. If I restore the ATV4k back to factory settings I am able to operate in 4k HDR for a day or two, sometimes not at all. I have had ATV4k since Christmas and have done a factory reset about 10 times. Anyone else with this issue?
     
  2. JWort93 macrumors member

    Joined:
    Aug 3, 2013
    #2
    This might sound odd, but my guess is your HDMI cable is not good enough. Have you tried other cables, specifically one that is HDMI Premium Certified?

    EDIT: Also, what model TV do you have? And do you run the Apple TV 4K through a receiver first, or does it connect directly to the TV?
     
  3. Berman1125, Feb 20, 2018
    Last edited: Feb 20, 2018

    Berman1125 thread starter macrumors newbie

    Joined:
    Sep 30, 2012
    #3
    I have a sony xbr900e55 the atv is connected directly to the tv with a hdmi premium certified cable

    EDIT: I am having some luck using it in 4k hdr 30hz instead of 60 hz. What do you think could be the hold up from allowing it to happen at 60 hz? Update...that didn't last long. Only working on 1080p now
     
  4. JWort93 macrumors member

    Joined:
    Aug 3, 2013
    #4
    Based on the fact that it worked better, even if just for a while at 30hz, still makes me think it’s an hdmi cable issue. I had very similar problems myself with some hdmi cables, even with the Belkin Ultra High Speed ones that Apple suggests, and they went away when I replaced them. If you live in the US near a Best Buy, I’d recommend picking up one of these, in any size that works for you, and giving it a try: https://www.bestbuy.com/site/rocket...wall-hdmi-cable-black/3720011.p?skuId=3720011 If it solves it, awesome, otherwise you can always return it no problem.
     
  5. Berman1125 thread starter macrumors newbie

    Joined:
    Sep 30, 2012
    #5
    Upon doing some digging into the hdmi cable that I got, it appears that they were not truthful about the hz that it handles. A lot of people complaining that they can only get it to work on 30hz. I am going to best buy tomorrow and will try that cable you suggest and will report back
     
  6. fsl2017 macrumors newbie

    Joined:
    Nov 16, 2017
    #6
    Hi,

    I suppose that you are having the same model as I have it here in Europe which is KD55X9005. I also have the 4k ATV connected directly connected to the TV. Important to notice: Only HDMI2 and HDMI3 support HDR and at the same time HDMI3 is the ARC port.

    See also here:

    https://community.sony.com/t5/4K-Ul...0e-which-HDMI-ports-are-4k-enabled/m-p/649978

    So I have the ATV4K connected to HDMI2 and the AV receiver is connected to HDMI3.

    I have a PC connected to HDMI1 and it will not drive 4k higher than 30Hz.

    Hope that helps.

    Frank
     
  7. Berman1125 thread starter macrumors newbie

    Joined:
    Sep 30, 2012
    #7
    I have only been using 2 and 3
     
  8. JWort93 macrumors member

    Joined:
    Aug 3, 2013
    #8
    Just curious, any luck with the new HDMI cable?
     
  9. Berman1125 thread starter macrumors newbie

    Joined:
    Sep 30, 2012
    #9
    I was able to purchase the suggested hdmi cable today and so far so good! We are rolling on 4k hdr 60hz like a champ! The only thing that's making me hesitate, is that I have been able to get it to work on 4k hdr 60 hz for a week or two when I first got the apple tv and after a few factory resets. The true test will be if this sucker holds up over a week or two. So far we are in good shape! Thanks alot
     
  10. ayetta macrumors newbie

    Joined:
    Jan 8, 2017
    #10
    I have the same exact issue. Bought both the ATV 4K AND the Belkin HDMI 4K they recommend at the Apple Store. And I’ve run three other High-speed hdmi Ethernet cables. Connected to a 4K TV and 4K-able Denon receiver. Sticks to 4K SD, with like 20hz. Can’t seem to break the barrier to the HD 60hz for some strange/stupid reason.
     
  11. Berman1125 thread starter macrumors newbie

    Joined:
    Sep 30, 2012
    #11
    What kind of TV do you have?
     
  12. Berman1125 thread starter macrumors newbie

    Joined:
    Sep 30, 2012
    #12
    Having issues again this morning...freezing up in 4k hdr but operating fine in 1080p hdr. I have the super fancy rabbit 4k hdr hdmi cable and 40mbps from my router at the moment. It is a rented router from the cable company. Does anyone think that upgrading that could potentially fix the issue?
     

Share This Page