ATWinFlash error, can't flash 7950

Discussion in 'Mac Pro' started by TableSyrup, Nov 5, 2015.

  1. TableSyrup macrumors 6502

    Joined:
    May 29, 2012
    #1
    I feel really really stupid right now.

    I've read a ton of posts, and not getting anywhere trying to flash my Leafblower, AMD Radeon HD7950

    I have a windows partition installed (XP)
    Catalyst installed
    GPU-Z shows everything properly
    I was able to save a copy of my original ROM

    ATIFLASH and WINFLASH will not operate. Winflash GUI version gives an error saying it is not a valid Win32 application

    The command prompt version says 'Exiting due to signal SIGSEGV general exception fault at eip=00039f37, and a bunch of other stuff I don't understand lol

    I have ROMINATORS 7950 Rom... but.... no way to flash the card.
    I also have a ROM that I made, but again... no way to flash it.

    ZEUS didn't work - ATI Flash Tool, download seems to have been erased from the interwebs .....

    I'm at a loss here.

    I've been at this, reading, following dead links, ALL DAY ! ! !

    Would someone be willing to provide some insight? I've never done anything like this before, and clearly shouldn't be lol
     
  2. BillyBobBongo, Nov 5, 2015
    Last edited: Nov 5, 2015
  3. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #3
    Unfortunately, I followed these instructions and I've had no luck

    The command prompt errors with what I described

    The GUI version errors as described

    Is the GUI version (accessible also from command prompt) only Win7? I have XP installed. Not working
     
  4. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #4
    Yeah... same issue still....... ALL DAY... no luck

    Can't get ATIflash to work

    could really use some help
     
  5. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
  6. TableSyrup, Nov 5, 2015
    Last edited: Nov 5, 2015

    TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #6
    Thanks for the suggestion. I did that, with a bootable USB. Same exact issue.

    Same exact issue with the 'Exiting due to signal SIGSEGV general exception fault at .....'

    I am really unsure what to do at this point
     
  7. VAGDesign macrumors 6502

    VAGDesign

    Joined:
    Feb 1, 2014
    Location:
    Greece
  8. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #8
    I've done everything in your guide. Actually followed through it (amongst a few others) yesterday.

    I was only able to boot to DOS on a Windows XP machine. Wondering how I could do that on the Mac Pro. I obviously don't have boot screens right now.... OSX doesn't give me the DOS Bootable USB drive as an option under Startup

    - one thing that may be an issue, in the Mac Pro, I did not use bootcamp to install. I manually installed XP on a drive.
    ... but... I am getting that same SIGSEGV error even on the Windows Machine booted directly to DOS... soooooo

    I'm really at a loss

    I'm gonna find someone with a Windows 7 machine I can throw the card in and try ATIWinFlash I think
     
  9. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #9
    Absolutely no luck. From DOS, Adapter not found... tried all 0-4.... tried force... etc... nothing.....

    command prompt method gives SIGSEV errors...

    Can't run the ATIWinFlash version on XP with 'not a valid win32 application' error.

    I have been trying in the mac pro, and trying in a PC.... tried directly via DOS boot.

    Nothing

    Card works fine under windows. Works fine under OSX, just no boot screens

    Switch position 1 or 2 does not matter, no effect

    GPU-Z still shows card properly.

    I'm just at a total loss... no idea.
     
  10. VAGDesign macrumors 6502

    VAGDesign

    Joined:
    Feb 1, 2014
    Location:
    Greece
    #10
    Have you tried the command to unlock the rom in case it's locked?
    Where was the switch while trying to write the new rom? One of the two positions is not writable.
    My XFX has no switch, so I used (atiflash -unlockrom 1) to unlock it and make it writable because XFX needs this command.

    I hope this helps.
     
  11. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #11
    I tried both switch positions

    I tried unlocking both switch positions.

    Same errors. No luck
     
  12. VAGDesign, Nov 6, 2015
    Last edited: Nov 6, 2015

    VAGDesign macrumors 6502

    VAGDesign

    Joined:
    Feb 1, 2014
    Location:
    Greece
  13. arivee macrumors newbie

    arivee

    Joined:
    Sep 13, 2015
    #13
    The errors you're encountering SEEM to be related to atiflash and the version of windows youre running is 32 bit. However, it would probably help if you outlined the exact steps you took. Hard to tell from just you saying you followed the process outlined in the different sites and threads.

    In my own journey, I can say the same but VAGDesigns was able to point out one simple error and it was from me following the steps verbatim.

    I suggest enumerating the actual process you took - then we can see where you went wrong. The process works - you're not catching what you're doing wrong - we're hearing the results - you now need to go into the details.

    I hope that helps.
     
  14. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #14
    OkeeDoke... sorry for any confusion.

    The one step I likely did not do right was the script to use my OEM rom to make a patched EFI rom.
    The patched rom I made, I did with Zeus, cause I got an error trying to do it with the Bundle from Netkas.
    To be dead honest, I don't know how/what to do to follow his instructions properly.
    Do I run terminal and script there? Do I run the readme? It says 'run the script' ... what script? How? lol
    ^SEE? I know nothing about this.... clearly lol

    So.... because I'm a total NOOB and shouldn't even be doing this, I have Rominators MAC7950.rom, and a 7950 Mac Edition.bin (Tried with the spaces in the name, and without).
    Both are reported to be good ROMs

    So....

    I don't have a copy of Windows 7, so I was unable to install Windows with Bootcamp, and Mavericks won't let me install XP via Bootcamp
    I removed all hard drives except the drive I wanted to use for Windows
    I booted from a Windows XP Install Disc, and installed Windows XP on the drive
    I am able to boot into windows on that drive
    I tried to install the BootCamp drivers, but they would not install
    Windows let me update to SP3

    From Windows, ATIWinflash 2.71 will not run - saying 'not a valid Win32 application'

    From Command prompt, running atiflash 3.99 or 4.17, I get the SIGSEGV error

    So, I made a USB DOS boot USB Flash Drive using the HP utility and the Windows 98 system files needed to do so

    I cannot boot my Mac Pro from that USB drive.... so.... I cobbled together a PC with Windows XP SP3, installed the card in that, and booted from DOS via the USB Flash Drive, and I get the same SIGSEGV error, and depending on commands, a 'Adapter Not Found' error

    I have tried all these things with my 7950 in switch position 1 and position 2
    I have tried all these things with cmd prompt, and from loading directly to DOS via the USB drive
    I've tried both the MAC7950.rom Rominator Rom, and the Mac Edition 7950.rom from the same thread at Netkas

    I am using , atiflash -f -p 0 romname.rom
    also tried the -fs
    no luck
    -i and -ai return the errors I've described.

    ^that said - in the mac, it is in position 0 (slot graphics card comes in by default)
    However, I did try 0-4 on both the mac, and on a PC I set up (XP)

    Does this info help?

    Maybe the fact that I am not doing this from an actual bootcamp install is an issue?

    As far as ATIWinFlash not working, is that cause I'm on XP?

    I am sure it is something I am doing wrong. I'm confident in that. Why atiflash 3.99 and 4.17 don't work via DOS on the PC that I set up, I have no idea.... but I'm thinking the reason I can't do this from the Mac is cause I can't boot into DOS directly from that... or at least, don;'t know how... and , the Winflash version won't run on my XP setup

    Sorry... I know I suck. lol
     
  15. VAGDesign macrumors 6502

    VAGDesign

    Joined:
    Feb 1, 2014
    Location:
    Greece
    #15
    Borrow a PC from a friend/family member and try AtiFlash (no AtiWinFlash). It's another app, I used it on DOS on both Mac Pro Running Windows 8.1 and PC for 2 different cards.
    Also, on the USB stick you'll put the bootable DOS files, add some previous versions of AtiFlash on separate folders with the rom included (e.g atiflash2.4 can be af24.exe with 7950.rom on a folder named af24) This way you know versions you tried and didn't work and you always have on same folder the .rom file to flash.

    This method I found out to be fast and reliable :)

    I hope this helps.
     
  16. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #16
    So... I was thinking it had to do with my Windows install on the Mac being XP, and not via Bootcamp.
    Not sure why the PC I setup wouldn't do it via DOS Bootable USB.... maybe too old a machine.

    At any rate, I called a local computer shop, they said come on by and use one of their machines.

    Less than 5 minutes, and a total of a $10 tip later, bam. done.

    Same exact procedure, and DOS USB I was using at my place.... worked flawlessly on the first attempt.

    So.... there ya have it. BIG THANK YOU to those that make this stuff possible (ATIflash, Netkas, Rominator, all other contributing members)

    Believe me when I tell you I did my reading and research, and plenty of trial, prior to my posting.
    So, I do apologize for any chaos. lol.
    I did understand 'how to do it' .... and was at a total loss as to why it didn't work, at least on the PC that I used.... but... it was something to do with the card not being seen in that PC... seriously crappy machine.... so who knows... lol

    I do have a follow up question for the future.

    Those of you that do this on your Mac Pro. How are you booting into DOS? If so, How?

    On a Mac Pro... are you using ATIWinFlash via Windows 7 or newer?
    I imagine ATIWinFlash wasn't working for me for one of two reasons.... 1, because I was on XP? 2, because my install was not via BootCamp, and was also missing BootCamp drivers in the Windows install.

    At any rate.... working flawlessly, PCI System report displays the card (twice though... I'll research why).
    I flashed with the 7950 Mac Edition ROM. DVI, and both mDP working.
    I had already removed R17, and the card is working at 5 GT/s

    Happy camper here. Thanks!
     
  17. dfritchie macrumors regular

    dfritchie

    Joined:
    Jan 28, 2015
    #17
    I used atiwinflash via XP on my mac, no problems at all. Made my own rom using netkas bundle. Windows installed via bootcamp.
     
  18. TableSyrup thread starter macrumors 6502

    Joined:
    May 29, 2012
    #18
    Ok, I presume it didn't work for me then because I did not use bootcamp to install XP (Mavericks wouldn't let me install XP... it wanted 7 or 8 or whatever) - in which case I didn't have any of the bootcamp drivers (tried to manually install those, which also failed)

    At any rate.... I was just told that you can get a Win7 or newer 'demo' ISO ... lol... had no idea.... in the event I need access to Windows again, I'll go that route and bootcamp it... but.... I avoid Windows like the plague .... I hate it with a passion these days.... I used to build my own machines that were solid, rock solid actually, back when XP was the big boy on the block and 32bit 4GB RAM was beefcake mode. But..... I've long since abandoned it and not looking back. Every time I need to touch windows it's a pain in the butt..... BUT it's good to know I can bootcamp a free version of newer Windows if needed again.
     

Share This Page