Audio and video stuttering, distortion and kernel panic

Discussion in 'MacBook' started by flipwuk, May 26, 2010.

  1. flipwuk macrumors newbie

    Joined:
    May 26, 2010
    #1
    Hi guys,

    I've been having this problem on my MacBook for over a year now, about time I got it sorted! After my exams at uni are done I'm planning to take it to a Genius Bar but I thought I'd plumb everyone on here's collective knowledge first!

    Here's the problem, whenever I'm listening to music or watching a video after a while the audio will drop out, stutter, or become horribly distorted. If I pause the video or music for a second then start playing it again the output will be okay for a few seconds to a few minutes then stutter again. If I leave it stuttering the output will either eventually go back to normal or just stay stuttering or muted. Once or twice I've got a 'you need to restart your computer' kernel panic error (log attached/linked to below) and twice my computer has seemingly randomly restarted itself.

    I know it's not an issue with my connection as it happens on locally stored files as well as streaming media.
    I know it's not a hard drive issue as I've had the problem across two different hard drives (I used the Migration Assistant to swap my stuff from one HD to another, presumably bringing across whatever causes the problem).
    I've had it with two sets of RAM as well.

    It happens whatever web browser (for streaming media) or music/video player I use for local files.

    If I restart the computer I get a longer period of time before the stuttering starts, and it gets more frequent the longer I leave my computer running - a RAM issue maybe?

    Here are some top and Activity Monitor outputs to help you guys, please let me know if there's anything else I can supply to help.

    These screengrabs where taken either during or shortly after the stuttering had taken place.

    [​IMG]
    [​IMG]
    [​IMG]

    This top output is after a particularly bad stutter:
    [​IMG]

    and here is a log following a kernel panic: http://www.philipwolstenholme.com/uploads/log after restart error.rtf

    From system info:
    [​IMG]
    [​IMG]
     
  2. flipwuk thread starter macrumors newbie

    Joined:
    May 26, 2010
    #2
    One other important thing - if I use my laptop to boot OS X from an external harddrive then video playback works fine. So it doesn't seem to be a hardware issue?
     
  3. flipwuk thread starter macrumors newbie

    Joined:
    May 26, 2010
    #3
    I've also ran Memtest checks with no errors occuring.
     
  4. zubon macrumors newbie

    Joined:
    Jan 24, 2008
    #4
    I am having this same exact problem and it's making me crazy as I can't figure out a solution. Any ideas or theories appreciated.
    I'm on a 2 GHz Intel Core 2 Duo Macbook, 10.6.4. I've reinstalled system software, upgraded everything, etc. Thanks.
     

Share This Page