Audio delay from rMBP

Discussion in 'Digital Audio' started by Geckotek, Nov 8, 2013.

  1. Geckotek macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
    #1
    I recently purchased a Sonos Play:5 and immediately started wanting to push audio from video sources to it. I don't have a monitor yet (waiting for BF) so I purchased an AirPort Express and connected it to the line input on the Play:5 (and configured it according to the Sonos documentation). When I tried to switch the audio on my rMBP to the Sonos, I found the audio from any video source to be delayed by 2-3 seconds.

    What was weird is a few days later on a whim I pushed a YouTube video from my iPhone to the Play:5 and noticed there was hardly any delay. I then tried my iPad and so far the only time I'm seeing that 2-3 second delay is from my rMBP.

    Usually I'm playing videos from Hulu or the CBS website. I've tested on both Safari and Chrome.

    Any ideas on how to resolve the audio delay from the rMBP?
     
  2. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #2
    The Airport Express delays the audio. It does it on purpose to avoid drop outs.

    If you want audio and video sync'd and send over the network you need an airplay device. Then everything is also delayed but it is in sync. An Apple TV will do that but not an AP Express.

    Why would you need an airport express if you already had a wireless speaker?
     
  3. Geckotek thread starter macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
    #3
    Because the wireless speaker does not support AirPlay.

    Later I'll be buying a monitor and using my ATV3. Hopefully having the audio out wired to the Sonos will resolve all this.
     

Share This Page