Audio Distortion at high CPU loads

Discussion in 'macOS' started by nabisco, Dec 13, 2009.

  1. nabisco macrumors newbie

    Joined:
    Sep 12, 2008
    #1
    hello,

    just wondering if this is a documented problem or if I should investigate further. A quick search of the forums turned up nothing.

    I have a Core Duo 2006 Macbook 2ghz, 2gb RAM, running 10.6.2 and whenever the CPU is taxed for an extended period of time, chances are I'll get some audio issues. What usually happens is that the audio will stutter for a second or so, then change instantly into a heavily distorted 'bitcrusher' output. The only way to resolve this is to restart whatever program is outputting audio. So far, this has happened in both Firefox & iTunes.

    Anybody ever seen something like this before?
     
  2. Scalfani macrumors member

    Joined:
    Aug 2, 2007
    #2
    I don't know how to fix it, but I had the same issue with 10.5.7, after updating to 10.5.8, the problem disappeared.

    Did you ever have the problem with 10.5.x ?

    I have the core 2 duo 2006 MBP.
     
  3. nabisco thread starter macrumors newbie

    Joined:
    Sep 12, 2008
    #3
    thanks for the reply. I skipped straight from Tiger to Snow Leopard so can't comment on Leopard performance sadly.

    I've noticed this problem with both built-in audio and an external Firewire soundcard. I use the Macbook for musical performance using Ableton Live and am quite concerned about this happening in the middle of a show.
     

Share This Page