Audio output device problems with El Capitan

Discussion in 'OS X El Capitan (10.11)' started by heathpitts, Nov 3, 2015.

  1. heathpitts macrumors member

    Joined:
    Jun 19, 2003
    #1
    Has anyone else had issues with making or receiving a call using handoff/continuity and the audio going out the wrong output? I've had this issue since the upgrade to El Capitan. It worked flawlessly for months with Yosemite.Setup is as follows: iPhone 6s, MacBook Pro retina 2014 model, Dell P2715q monitor with external speakers attached to that. When my iPhone rings, FaceTime on the Mac will start ringing as well through the external speakers. However, when I answer, the sound comes thru the internal speakers. When I check the audio output it is still set to the display port output. I have to select internal speakers and then select the display port to get the sound to go to the externals. A call to Apple was no luck either. They had me reset the PRAM and the SMC. They also said this was the first time they're hearing of the issue.

    Anyone else with this problem or know of anything I can try to fix it?
     
  2. lankox macrumors regular

    Joined:
    Jul 5, 2007
    #2
    Same problem
     
  3. lankox macrumors regular

    Joined:
    Jul 5, 2007
    #3

    Still having this problem daily. Any resolution?
     
  4. heathpitts thread starter macrumors member

    Joined:
    Jun 19, 2003
    #4
    Nothing that I have found will fix it
     
  5. heathpitts thread starter macrumors member

    Joined:
    Jun 19, 2003
    #5
    Well, I might have found something that has helped. Instead of changing the output with an option + click on the speaker icon, I changed it in the FaceTime app under "Video". After changing it there, it has stayed on the external speakers all day. I'll post again if this changes.
     
  6. heathpitts thread starter macrumors member

    Joined:
    Jun 19, 2003
    #6
    As an update, this doesn't completely fix the issue. It keeps it on the external output as long as I keep the screen awake. However, when I let the external monitor sleep, it goes back to the internal for sound.
     

Share This Page