Audio switching to 'tinny' profile?

Discussion in 'macOS' started by Mohammad001, Dec 30, 2016.

  1. Mohammad001 macrumors newbie

    Joined:
    Nov 26, 2016
    #1
    I'm not exactly sure what the title should be. I'm using some Bluetooth headphones and they connect perfectly with my MacBook Pro. Thing is, whenever I receive a Skype call (I believe anything where a microphone is involved), it switches to "tinny" sound quality.

    Not sure why this is - it happened on my old Windows laptop as well. On Windows, you can go to the sound preferences and choose whether it should output the sound through 'Headphones' or 'Headphones - Handsfree'. When it is on handsfree, the audio turns tinny as well.

    How can I make sure it always is connected to non-handsfree in macOS? Lately, a video application I use (that doesn't use the microphone) periodically switches to the tinny sound profile, making the video sound terrible.

    I can reproduce the sound by playing something in the background, go to Sound preferences -> Input and select the bluetooth device. If I instead select the Internal Microphone, the MacBook will still switch to the other tinny profile.

    Any idea? Maybe I can completely delete the bluetooth headphone from the "Input"?
     
  2. bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #2
    I thought I was the only one. Happens to me too, with my JBL Reflect Bluetooth earbuds. I get it when playing movies with VLC. Sometimes, fforgetting and recomnecting the Bluetooth device works.

    This all happened with the 10.12.2 update. A bit annoying :(
     
  3. Mohammad001 thread starter macrumors newbie

    Joined:
    Nov 26, 2016
    #3
    Shouldn't this happen to all Bluetooth headphone users? I tried another pair of bluetooth headphones with the same result. I can't really see why this 'feature' is useful at all, so why is it even there?

    I tried forgetting the device, I couldn't really get it to work even after several attempts. Still hoping for a solution. :)
     
  4. bartvk, Jan 1, 2017
    Last edited: Jan 1, 2017

    bartvk macrumors 6502

    bartvk

    Joined:
    Dec 29, 2016
    Location:
    The Netherlands
    #4
  5. Mohammad001 thread starter macrumors newbie

    Joined:
    Nov 26, 2016
    #5
    I don't have the Bluetooth Explorer option? I did try installing it from elsewere, it didn't work for me either.

    A lot of people are having the same problem. Apparently, the bandwidth on Bluetooth doesn't allow both high quality audio and microphone at the same time..

    In any case, the solution is to disable the microphone/handsfree mode on the headphone. Still not sure how to do that. An option exists in Bluetooth Explorer under Audio Options, but it didn't work.
     
  6. CMoore515 macrumors member

    Joined:
    Sep 27, 2015
    Location:
    Des Moines, IA
    #6
    Happens all the time on various headsets for me. Think it's "normal" more or less.
     
  7. Mohammad001 thread starter macrumors newbie

    Joined:
    Nov 26, 2016
    #7
    I'm sure it is, doesn't mean we shouldn't try to find a solution for it.

    Whenever the tinny audio starts, I always end up not watching that particular video. I can't even use Siri on my computer with Bluetooth headphones connected.
     

Share This Page