Authorization help needed..

Discussion in 'iPod' started by kayem1, Jan 11, 2009.

  1. kayem1 macrumors newbie

    Jan 11, 2009
    Hey everyone.
    I'm having trouble with authorization.
    All of my purchases continually require authorization.
    When I type in my password it says that my computer is already authorized and is the one of 5 computers that have been authorized. But it still continually asks every time I try to play a song, therefore rendering my songs unplayable.

    I have de-authorized all computers and this computer and tried again.
    I've been through all the steps in the knowledge base help article for these symptoms without success.

    I then tried to upgrade my purchased items to be DRM free but some wouldn't, even though on the store it says they're available to iTunes plus.
    It even says some aren't available on the Australian store, but that is what I used to purchase them in the first place.

    Anyone have a solution for this?
  2. JediMeister macrumors 68040

    Oct 9, 2008
    One thing you could try to do, if you haven't already done so, is to uninstall/reinstall iTunes. I have seen it fix issues with connecting to the iTunes Store and authorization. There could also possibly be a problem with the .itl database file as well if its not recognizing that you're authorized to playback all that content...
  3. yourdream macrumors regular

    Aug 16, 2008
    If the solution above does not work, you can try calling Apple, I'm sure they can help you with your problem.
  4. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    I hate that error. This is why DRM is bad and why I'm pleased to see Apple finally taking unprotected music seriously. Now if only it gets extended to the whole store...

  5. msc66 macrumors newbie

    Feb 14, 2009
    ever solved?

    Was this issue ever resolved? I'm having the same problem.

Share This Page