Authorization problems with itunes?

Discussion in 'Mac Apps and Mac App Store' started by JellyFish, Aug 12, 2007.

  1. JellyFish macrumors regular

    Joined:
    Jun 15, 2007
    #1
    I just restored music and audio books off a CD that I'd backed up from my powermac. I restored it to my new iMac. However, itunes keeps asking me for authorization over and over again. It says my machine is authorized but then when I click to play a song, it keeps asking me for authorization ID and password but won't play the song.

    What am I doing wrong here?
     
  2. RobP macrumors member

    Joined:
    Mar 3, 2009
    #2
    Exactly the same here. When I go to sync my iPod touch it says that iTunes needs to be authorized. I then go an authourize it and the iTunes store says that the machine is already authorized and that I have used 3 registrations out of 5.

    Once I accept the dialog to say the machine is already authourized I get another dialog telling me my machine isn't and around the cycle I go again.:confused:

    The only thing out of the ordinary is that I originally tried to sync my iPod with my computer disconnected from the internet as I wanted to copy some demos that I had written. It was from this point that the problems have occurred.

    I have tried the obvious things like switching on the internet and rebooting, but nothing seems to work. It looks like iTunes and its DRM is turning my iPod into an expensive brick.

    RobP
     
  3. Dino451 macrumors 6502

    Joined:
    Sep 12, 2006
    #3
    try reinstalling itunes/ get the latest version
     

Share This Page