Auto-Brightness & iPhone 3G: Anyone else?

Discussion in 'iPhone' started by Nikhil72, Jul 15, 2008.

  1. Nikhil72 macrumors 65816

    Oct 21, 2005
    So I exchanged my first iPhone 3G for another one at the Apple Store today because of battery (today, with 3G, WiFi, and Push off, and Fetch for 15 minutes on, I was only able to get about 5 hours of iPod-based music playback before the phone died).

    I noticed that when Auto-Brightness is set on the 3G, its brightness level seems to move *upwards* (i.e. it hovers towards the higher end of the spectrum) whereas my 2G tends to turn brightness down. This occurs no matter where I set the manual slider (which, I'm learning, sets a rough "middle-ground" about which Auto-Brightness functions...i.e., if I set the slider at 50% and then turn on Auto-Brightness, it will range anywhere from ~40-60% brightness).

    Does anyone else notice that their 3G's Auto-Brightness tends to hover on the higher side? Or have I lost my mind?

    (and I'm loving my 3G).
  2. djwobble macrumors regular

    Jul 10, 2008
    Virginia Beach, Virginia
    How did you get them to exchange your iphone so quickly?
  3. Nikhil72 thread starter macrumors 65816

    Oct 21, 2005
    I just made an appointment at the Genius Bar...they heard what I had to say, ran the diagnostics from the phone, and then they swapped me a full retail package phone.
  4. eldersi macrumors newbie

    Jul 15, 2008
    Lancaster, PA
    yep, me too

    You're not losing your mind! I'm having the exact same issue and came to these forums hoping to find an answer. I have the white iPhone. It does not matter on the lighting around the iPhone, the screen brightness will jump up as it pleases. I'm doing a restore as I type this and plan on keeping it basic for a day to make sure nothing else is messing with it (3rd party apps).

    Very strange. I really hope it's a bug in the OS and not hardware. I went through 4 iPhones prior to the 3G, I really don't want a repeat. Besides this, I'm loving it.

  5. Nikhil72 thread starter macrumors 65816

    Oct 21, 2005
    I notice that it does seem to behave properly, but only after turning the device off and on again (i.e. turn auto-brightness on; turn light off, turn iPhone off and on again, the screen is dim...turn the light on, the screen brightens). It just seems that the 3G seems to be running at a higher brightness level (significantly) than the 2G despite the bar being at the same location.
  6. sgiles1 macrumors newbie

    May 23, 2008
    I noticed this as well tonight. Out of the blue it suddenly got very bright even though the ambient room light didn't change. When I checked my brightness setting it was at auto and the level was set at about 30% (which is where I had set it earlier in the day).
  7. Nikhil72 thread starter macrumors 65816

    Oct 21, 2005
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5A347 Safari/525.20)

    interesting. Now, normally, it's supposed to work by setting a range around the manual slider, correct?

    In practice, auto-brightness should help conserve battery life.
  8. Nikhil72 thread starter macrumors 65816

    Oct 21, 2005
    It's still happening despite a restore and it's driving me nuts. Time to disable auto-brightness I think
  9. joshd macrumors newbie

    Jul 12, 2008
    I've seen this too. Almost as if it gets brighter in a darker situation and darker in a lighter situation.
  10. Scott-n-Houston macrumors 6502a

    Apr 27, 2008
    Houston (duh)
    Don't know how old this thread is, but I did a search and found it on google because I noticed this last night. I was in a pitch black room, and it was WAY bright. I went to brightness, my slider was at about 30-40%, and if I turned off Auto Brightness, it would go darker! Turn it back on, and it would go lighter. Auto Brightness was taking it to about the highest bright setting there is.
  11. Nikhil72 thread starter macrumors 65816

    Oct 21, 2005
    yup, still doing it. I've turned off auto-brightness.
  12. alFR macrumors 68020

    Aug 10, 2006

Share This Page